hdoj 4745 dp 最长回文子序列

76 篇文章 0 订阅

Two Rabbits

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 2425    Accepted Submission(s): 1254


 

Problem Description

Long long ago, there lived two rabbits Tom and Jerry in the forest. On a sunny afternoon, they planned to play a game with some stones. There were n stones on the ground and they were arranged as a clockwise ring. That is to say, the first stone was adjacent to the second stone and the n-th stone, and the second stone is adjacent to the first stone and the third stone, and so on. The weight of the i-th stone is ai.

The rabbits jumped from one stone to another. Tom always jumped clockwise, and Jerry always jumped anticlockwise.

At the beginning, the rabbits both choose a stone and stand on it. Then at each turn, Tom should choose a stone which have not been stepped by itself and then jumped to it, and Jerry should do the same thing as Tom, but the jumping direction is anti-clockwise.

For some unknown reason, at any time , the weight of the two stones on which the two rabbits stood should be equal. Besides, any rabbit couldn't jump over a stone which have been stepped by itself. In other words, if the Tom had stood on the second stone, it cannot jump from the first stone to the third stone or from the n-the stone to the 4-th stone.

Please note that during the whole process, it was OK for the two rabbits to stand on a same stone at the same time. 

Now they want to find out the maximum turns they can play if they follow the optimal strategy.

 

 

Input

The input contains at most 20 test cases.
For each test cases, the first line contains a integer n denoting the number of stones.
The next line contains n integers separated by space, and the i-th integer ai denotes the weight of the i-th stone.(1 <= n <= 1000, 1 <= ai <= 1000)
The input ends with n = 0.

 

 

Output

For each test case, print a integer denoting the maximum turns.

 

 

Sample Input

 

1 1 4 1 1 2 1 6 2 1 1 2 1 3 0

 

 

Sample Output

 

1 4 5

Hint

For the second case, the path of the Tom is 1, 2, 3, 4, and the path of Jerry is 1, 4, 3, 2. For the third case, the path of Tom is 1,2,3,4,5 and the path of Jerry is 4,3,2,1,5.

不难发现 兔子走的其实左右 左边走一遍 右边走一遍 不就是最长回文子序列吗?
然后现在的问题是如何找这个最长回文子序列

我们可以用最普通的方法求出区间内的最长回文子序列 那么让两个区间相加

如A的区间内的最长回文子序列 加上B的最长回文子序列

为什么可以加呢 我们这样想 你既然是回文的 那么A + B 和 B + A 对称 也就是 A B A 是我们需要的

为啥A + B就是答案呢 你这样想 假设A在B左边 A从最左边走到B 最右边 是不是向右走?

那么B在A左边的时候 A最后边 走到B最左边 是不是向左走?

那么这个长度相加是不是他们走的最长长度?

所以答案只要跑完长度 进行枚举取最大值即可

 

/*
hdoj 4745
*/
#include <cstdio>
#include <cstring>
#include <iostream>
#include <cmath>
#include <algorithm>
#include <cstring>
#include <vector>
#define dbg(x) cout<<#x<<" = "<< (x)<< endl
using namespace std;
const int MAX_N = 1024;
int arr[MAX_N*2],arr_new[MAX_N*2];
      int dp[MAX_N][MAX_N];
int main(){
   int n;
   while(scanf("%d",&n)&&n){
    for(int i = 0;i<n;++i)
        scanf("%d",&arr[i]);
     int maxx = -1;
     if(n==1){
        printf("1\n");
        continue;
     }


            for(int i=n-1;i>=0;i--){
                dp[i][i]=1;
                for(int j=i+1;j<n;j++){
                    if(arr[i]==arr[j])
                        dp[i][j]=dp[i+1][j-1]+2;
                    else
                        dp[i][j]=max(dp[i+1][j],dp[i][j-1]);
                }
            }
       for(int i = 0;i<n;i++){
        //dbg()
        maxx = max(dp[0][i]+dp[i+1][n-1],maxx);
       }
    printf("%d\n",maxx);
     }
   return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值