hdu 2669(拓展欧几里得)

Romantic

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


Problem Description
The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You.
................................Write in English class by yifenfei



Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.
 

Input
The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a, b<=2^31)
 

Output
output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead.
 

Sample Input
  
  
77 51 10 44 34 79
 

Sample Output
  
  
2 -3 sorry 7 -3
解题思路:这道题目其实直接套模板就ok了,只是要稍微做点修改。。首先gcd(a,b)=1,其次x>=0,第一个好办,第二个条件可以这么处理:在刘汝佳的《算法竞赛入门经典》里,有一个这样的结论:设a,b,c为任意整数。若方程ax+by=c的一组整数解为(x0,y0),则它的任意整数解都可以写成(x0+kb',y0-ka'),其中a'=a/gcd(a,b),b'=b/gcd(a,b),k取任意整数。那么可以根据这个结论,如果x<0,可以把x一直加b',y一直减a',直到x>=0为止。。
AC:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

typedef __int64 LL;
LL extend_gcd(LL a,LL b,LL &x,LL &y)
{
	if(a == 0 && b == 0) return -1; //无最大公因子
	if(b == 0)
	{
		x = 1; y = 0;
		return a;
	}
	LL d = extend_gcd(b,a%b,y,x);
	y -= (a/b)*x;
	return d;
}

int main()
{	
	LL a,b;
	while(cin>>a>>b)
	{
		LL x,y,d;
		d = extend_gcd(a,b,x,y);
		if(d == 1)
		{
			while(x < 0)
			{
				x += b/d;
				y -= a/d;
			}
			cout<<x<<' '<<y<<endl;
		}
		else
			cout<<"sorry"<<endl;
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值