HDOJ 5783 Divide the Sequence(贪心)

Divide the Sequence

Time Limit: 5000/2500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 427    Accepted Submission(s): 235


Problem Description
Alice has a sequence A, She wants to split A into as much as possible continuous subsequences, satisfying that for each subsequence, every its prefix sum is not small than 0.
 

Input
The input consists of multiple test cases.
Each test case begin with an integer n in a single line.
The next line contains n integers A1,A2An .
1n1e6
10000A[i]10000
You can assume that there is at least one solution.
 

Output
For each test case, output an integer indicates the maximum number of sequence division.
 

Sample Input
  
  
6 1 2 3 4 5 6 4 1 2 -3 0 5 0 0 0 0 0
 

Sample Output
  
  
6 2 5
 

Author
ZSTU
 

Source


思路:
题意是让你把长度为n的序列分成尽量多的连续段,使得每一段的每个前缀和都不小于0。保证有解。 从后往前贪心分段即可。首先你要知道什么叫字符串的前缀。就比如1231,它的前缀就是1、12、123三种。所以说,第一个数一定不能是负数、第二个和第一个的和一定也不是负数,直到遇到一个负数把他们都抵消了。从前往后推的话挺麻烦,要考虑的情况很多,所以考虑从后往前推。遇到非负数就把它独立划分成一段,然后如果遇到了负数,就往后继续推,并且用sum进行加和,直到到负数后的某个位置,sum由负变成了非负,这个时候把这一串也划分成一段。因为题目中说肯定有解,所以不用考虑到最后会划不成一组的情况。


代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;
typedef long long ll;
const int maxn=1000000+10;
int a[maxn];
int main(int argc, const char * argv[]) {
    ll n;
    while(scanf("%lld",&n)==1)
    {
    	memset(a,0,sizeof(a));
     	ll sum=0,cnt=0;
        for(ll i=1;i<=n;i++) scanf("%d",&a[i]);
        for(ll i=n;i>=1;i--)
        {
            if(a[i]>=0&&sum>=0)
			{
				cnt++;
				sum=0;
				continue;
			}
			else
			{
				sum=sum+a[i];
				if(sum>=0)
				{
					cnt++;
					sum=0;
				}
			}
        }
        cout<<cnt<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值