PAT甲级 -- 1002 A+B for Polynomials (25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

15分 好多点没过 

#include <iostream>
#include <cmath>
#include <set>
using namespace std;



int ka, kb, ex, mx = -1, mn = 20, n = 0; //mx系数最高次,n是项数
double a[1010], b[1010], c[1010];  //指数为i的系数
double xishu;
set<int> xiangshu;

int main()
{
    scanf("%d", &ka);
    for(int i = 0; i < ka; i++)
    {
        scanf("%d %lf", &ex, &xishu);
        a[ex] = xishu;
        xiangshu.insert(ex);
        mx = max(mx, ex);
        mn = min(mn,ex);
    }
    scanf("%d", &kb);
    for(int i = 0; i < kb; i++)
    {
        scanf("%d %lf", &ex, &xishu);
        b[ex] = xishu;
        xiangshu.insert(ex);
        mx = max(mx, ex);
        mn = min(mn,ex);
    }

    printf("%d ", xiangshu.size());
    for(int i = mx; i >= mn; i--)
    {
        if(i != mn)
        {
            c[i] = a[i] + b[i];
            printf("%d %.1f ", i, c[i]);
        }else
        {
            c[i] = a[i] + b[i];
            printf("%d %.1f", i, c[i]);
        }

    }

    return 0;
}

 

满分代码:

#include<cstdio>
#include<iostream>
using namespace std;
const int maxn = 1111;
double p[maxn] = {};
int main() {
    int k, n, count = 0;
    double a;
    scanf("%d", &k);
    for(int i = 0; i < k; i++) {
        scanf("%d %lf", &n, &a);
        p[n] += a;
    }
    scanf("%d", &k);
    for(int i = 0; i < k; i++) {
        scanf("%d %lf", &n, &a);
        p[n] += a;
    }
    for(int i = 0; i < maxn; i++) {
        if(p[i] != 0) {
            count++;
        }
    }
    printf("%d", count);
    for(int i = maxn; i >= 0; i--) {
        if(p[i] != 0) {
            printf(" %d %.1f", i, p[i]);
        }
    }
    return 0;
}

照着满分修改后代码:

竟然只有2分了  我真的迷醉 和满分代码没差呀????

#include <iostream>
using namespace std;



int ka, kb, ex, n = 0; //mx系数最高次,n是项数
double a[1010] = {0};  //指数为i的系数
double xishu;

int main()
{
    scanf("%d", &ka);
    for(int i = 0; i < ka; i++)
    {
        scanf("%d %lf", &ex, &xishu);
        a[ex] += xishu;
    }
    scanf("%d", &kb);
    for(int i = 0; i < kb; i++)
    {
        scanf("%d %lf", &ex, &xishu);
        a[ex] += xishu;
    }
    for(int i = 1010; i >= 0; i--)
    {
        if(a[i] != 0)
        {
            n++;
        }
    }
    printf("%d", n);
    for(int i = 1010; i >= 0; i--)
    {
        if(a[i]!=0)
        {
            printf(" %d %.1f", i, a[i]);
        }
    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值