PAT甲级 -- 1110 Complete Binary Tree (25 分)

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤20) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line YES and the index of the last node if the tree is a complete binary tree, or NO and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:

9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -

Sample Output 1:

YES 8

Sample Input 2:

8
- -
4 5
0 6
- -
2 3
- 7
- -
- -

Sample Output 2:

NO 1

 思路:

1. 有n个结点的二叉树,当且仅当其每一个结点都与深度为K的满二叉树中编号从1至n的结点一一对应时称之为完全二叉树。

2. 递归树中最大的下标值,看最大下标值是否等于节点个数,若等于则说明是满二叉树,不等于说明不是

3. 用变量maxn记录最大的下标值,ans记录最后一个结点,root为起始根节点

 

#include <iostream>
#include <vector>
#include <cmath>
#include <string>
#include <queue>
#include <algorithm>
using namespace std;

struct node
{
	int left, right; 
}tree[100];
int n;
int maxn = -1, ans;


void dfs(int root, int index){
	if (index > maxn){
		maxn = index;
		ans = root;
	}
	if(tree[root].left != -1) dfs(tree[root].left, index*2);
	if(tree[root].right != -1) dfs(tree[root].right, index*2+1);
}


int main(){
	scanf("%d", &n);
	int hash[100] = {0} ,root = 0;
	for(int i = 0; i < n; i++){
		string n1, n2;
		cin >> n1 >> n2;
		if (n1 == "-") tree[i].left = -1;
		else{
			tree[i].left = stoi(n1);
			hash[stoi(n1)] = 1;
		}
		if (n2 == "-") tree[i].right = -1;
		else{
			tree[i].right = stoi(n2);
			hash[stoi(n2)] = 1;
		}
	}
	while(hash[root] != 0) root++;
	dfs(root,1);
	if (maxn == n){
		printf("YES ");
		printf("%d", ans);
	}else{
		printf("NO ");
		printf("%d", root);
	}
	return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值