HDU - 5747 Aaronson

Aaronson

HDU - 5747

AYIT-2021 609暑假集训第一周 周赛题

Recently, Peter saw the equation x0+2x1+4x2+…+2mxm=n. He wants to find a solution (x0,x1,x2,…,xm) in such a manner that ∑i=0mxi is minimum and every xi (0≤i≤m) is non-negative.

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤105), indicating the number of test cases. For each test case:

The first contains two integers n and m (0≤n,m≤109).

Output

For each test case, output the minimum value of ∑i=0mxi.

Sample Input

10
1 2
3 2
5 2
10 2
10 3
10 4
13 5
20 4
11 11
12 3

Sample Output

1
2
2
3
2
2
3
2
3
2

题意:已知n和m,根据式子x0+2x1+4x2+…+2mxm=n,求 ∑i=0mxi最小值
题型:贪心
思路:有式子易知当2m的系数为0或1时最后的系数和最小,但是有m有限制,所以先按照从大到小的顺序求系数,若当前系数的m不在题目给的范围内,则转换成范围内的最大值的系数

#include<stdio.h>
#include<math.h>
int main()
{
	int t,n,m,i,sum,nn,mm;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);mm=1<<m;
		for(sum=0,i=log2(n);i>=m;i--)//log2(n)是公式里最大的幂
		{
			if(!(n/(nn=1<<i)))continue;//如果系数是0跳过
			sum+=nn/mm;n-=nn;//n/mm表示当前系数转换成的限制的最大幂的系数,然后更新n的值(n减去当前项的值)
		}
		for(;i>=0;i--)//上面的循环是理论系数都是0或1时的最大幂到限制的幂m,此循环是幂m到幂0
		{
			if(!(n/(nn=1<<i)))continue;
			sum+=n/nn;n%=nn;//n/nn直接就是规定范围幂的系数,然后更新n的值(n减去当前项的值)
		}
		printf("%d\n",sum);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值