hdu 4734 F(x) 数位DP

Problem Description
For a decimal number x with n digits (A nA n-1A n-2 ... A 2A 1), we define its weight as F(x) = A n * 2 n-1 + A n-1 * 2 n-2 + ... + A 2 * 2 + A 1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).
 

Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
For each test case, there are two numbers A and B (0 <= A,B < 10 9)
 

Output
For every case,you should output "Case #t: " at first, without quotes. The t is the case number starting from 1. Then output the answer.
 

Sample Input
  
  
3 0 100 1 10 5 100
 

Sample Output
  
  
Case #1: 1 Case #2: 2 Case #3: 13
  题意:给定A和B,求给定区间1~B中的x对应的f(x)小于f(A)的数。
F(x) = An * 2n-1 + An-1 * 2n-2 + ... + A2 * 2 + A1 * 1;
思路:简单的数位DP+记忆化搜索,唯一注意的一点是初始化DP的时候要放在外面防止超时;
代码:
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int dp[15][50000],b[15];
int f(int n)
{
    int ans=0,t=1;
    while(n)
    {
        ans+=(n%10)*t;
        t=t*2;
        n=n/10;
    }
    return ans;
}
int dfs(int len,int ans,int flag)
{
    if(len<=0&&ans>=0)
        return 1;
    if(ans<0)
        return 0;
    if(!flag&&dp[len][ans]!=-1)
        return dp[len][ans];
    int end=flag?b[len]:9;
    int s=0;
    for(int i=0;i<=end;i++)
    {
        s=s+dfs(len-1,ans-i*(1<<(len-1)),flag&&i==end);
    }
    if(!flag)
        dp[len][ans]=s;
    return s;
}
int find(int n,int m)
{
    int len=0;
    while(m)
    {
        b[++len]=m%10;
        m=m/10;
    }
    return dfs(len,f(n),1);
}
int main()
{
    int t;
    scanf("%d",&t);
    memset(dp,-1,sizeof(dp));  //注意放在外面
    for(int T=1;T<=t;T++)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        printf("Case #%d: ",T);
        printf("%d\n",find(n,m));
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值