poj 3468 A Simple Problem with Integers(线段树+延迟标记)

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

Source



题意:
Q是询问区间和,C是在区间内每个节点加上一个值;
思路:明显的线段树,只是在更新的时候如果更新到叶子节点会超时,所以要用到延迟标记,即如果更新到某一个区间,我们用一个变量add记录此区间的增量,无需往下继续更新,当以后再次访问此区间时,如果要访问改区间的子区间,我们再往下更新,如此可以节省好多时间;
代码:
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int N=100005;
struct node{
    int l,r;
    __int64 w,add;
}str[3*N];
void build(int l,int r,int n)
{
    str[n].l=l;
    str[n].r=r;
    str[n].add=0;
    if(l==r)
    {
        scanf("%I64d",&str[n].w);
        return;
    }
    int temp=(l+r)/2;
    build(l,temp,2*n);
    build(temp+1,r,2*n+1);
    str[n].w=str[2*n].w+str[2*n+1].w;
}
void push(int n)
{
    int temp=(str[n].l+str[n].r)/2;
    str[2*n].add+=str[n].add;
    str[2*n+1].add+=str[n].add;
    str[2*n].w+=(str[n].add)*(temp-str[2*n].l+1);
    str[2*n+1].w+=str[n].add*(str[n].r-temp);
    str[n].add=0;
}
__int64 query(int l,int r,int n)
{
    if(str[n].l==l&&str[n].r==r)
        return str[n].w;
    if(str[n].add)
        push(n);
    int temp=(str[n].l+str[n].r)/2;
    if(r<=temp)
        return query(l,r,2*n);
    else if(l>temp)
        return query(l,r,2*n+1);
    else
        return query(l,temp,2*n)+query(temp+1,r,2*n+1);
}
void update(int l,int r,int w,int n)
{
    if(str[n].l==l&&str[n].r==r)
    {
        str[n].w+=w*(r-l+1);
        str[n].add+=w;
        return;
    }
    if(str[n].add)
       push(n);
    int temp=(str[n].l+str[n].r)/2;
    if(r<=temp)
        update(l,r,w,2*n);
    else if(l>temp)
        update(l,r,w,2*n+1);
    else
    {
        update(l,temp,w,2*n);
        update(temp+1,r,w,2*n+1);
    }
    str[n].w=str[2*n].w+str[2*n+1].w;
}
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        build(1,n,1);
        char c[10];
        while(m--)
        {
            scanf("%s",c);
            if(c[0]=='Q')
            {
                int a,b;
                scanf("%d%d",&a,&b);
                printf("%I64d\n",query(a,b,1));
            }
            else
            {
                int a,b,w;
                scanf("%d%d%d",&a,&b,&w);
                update(a,b,w,1);
            }
        }
    }
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值