交叉的梯子PKU2507

Crossed ladders

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5476 Accepted: 2070

Description

A narrow street is lined with tall buildings. An x foot long ladder is rested at the base of the building on the right side of the street and leans on the building on the left side. A y foot long ladder is rested at the base of the building on the left side of the street and leans on the building on the right side. The point where the two ladders cross is exactly c feet from the ground. How wide is the street? 

Input

Each line of input contains three positive floating point numbers giving the values of x, y, and c.

Output

For each line of input, output one line with a floating point number giving the width of the street in feet, with three decimal digits in the fraction.

Sample Input

30 40 10
12.619429 8.163332 3
10 10 3
10 10 1

Sample Output

26.033
7.000
8.000
9.798

Source

The UofA Local 2000.10.14

菜是什么菜?就是每做一个题都需要写题解;  ……> _ <……

 公式推导+二分

#include<cstdio>
#include<iostream>
#include<iomanip>
#include<cstdlib>
#include<cmath>
using namespace std;
double x, y, c; 

bool f(double w) {
	double a,b;
	a = sqrt(x * x - w * w);
	b = sqrt(y * y - w * w);
	if(a * b >= c * (a + b)) return 0;
	else return 1; 
}

int main() {
	while(cin >> x >> y >> c) {
		double left = 0,right = x > y ? y : x,mid; //意思是以最短的楼梯作为街宽的最大然后进行二分

		while(right - left > 1e-4) {
			mid = (right + left) / 2.0;
			if(f(mid) == 0) left = mid;  //如果小于继续往大二分
			else right = mid;
		}
		cout << fixed << setprecision(3) << left << endl;
	}
	return 0;
}  

公式推导:

  • 设x梯子高为a,y梯子高为b,底边为d;
  • 则:c/a = d1/d, c/b = d2/d;
  • 因d1 + d2 = d,故c/a + c/b = 1;
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值