hdu-oj 1570 AC

A C

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3773    Accepted Submission(s): 2412


Problem Description
Are you excited when you see the title "AC" ? If the answer is YES , AC it ;

You must learn these two combination formulas in the school . If you have forgotten it , see the picture.




Now I will give you n and m , and your task is to calculate the answer .
 Input
In the first line , there is a integer T indicates the number of test cases.
Then T cases follows in the T lines.
Each case contains a character 'A' or 'C', two integers represent n and m. (1<=n,m<=10)
 Output
For each case , if the character is 'A' , calculate A(m,n),and if the character is 'C' , calculate C(m,n).
And print the answer in a single line.
 Sample Input
  
  
2 A 10 10 C 4 2
 Sample Output
  
  
3628800 6
求阶乘
附代码:
#include <stdio.h>
int main()
{   int t,n,m,i,j;
    char ch;
    scanf("%d",&t);
    getchar();
    while(t--){
     scanf("%c%d%d",&ch,&n,&m);
     int sum=1;
		for(int i=n;i>n-m;i--)
		{
			sum=sum*i;
		}
	    if(ch=='A') printf("%d\n",sum);
		if(ch=='C') 
		{
			int num=1;
			for(int j=m;j>0;j--)
			{
				num=num*j;
			}
		 printf("%d\n",sum/num);
		}
		getchar();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值