HDU 2444 The Accomodation of Students

The Accomodation of Students

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2666    Accepted Submission(s): 1244


Problem Description
There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.
 

Input
For each data set:
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.

 

Output
If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms.
 

Sample Input
  
  
4 4 1 2 1 3 1 4 2 3 6 5 1 2 1 3 1 4 2 5 3 6
 

Sample Output
  
  
No 3
解题思路:给定一些人和他们之间的认识关系,即A认识B,B也认识A,但是认识关系不能传递,现在问你是否能将他们分为2组,组内成员互不认识,可以的话最多能有多少对人可以把他们放入双人间,前者就是问图是否为二分图,我用并查集搞的,后者就是最大匹配数/2
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int father[205],map[205][205],pre[205];
bool used[205];
void ini()
{
    int i;
    for(i=1;i<205;i++)
        father[i]=i;
}
int find(int x)
{
    if(x==father[x])
        return x;
    return father[x]=find(father[x]);
}
bool ok(int x,int n)
{
    int i;  
    for(i=1;i<=n;i++)  
    {  
        if(!used[i]&&map[x][i])  
        {  
            used[i]=true;  
            if(pre[i]==-1||ok(pre[i],n))  
            {  
                pre[i]=x;  
                return true;  
            }  
        }  
    }  
    return false;  
}
int MMG(int n)
{
    int i,count=0;
    memset(pre,-1,sizeof(pre));
    for(i=1;i<=n;i++)
    {
        memset(used,0,sizeof(used));
        if(ok(i,n))
            count++;
    }
    return count;
}
int main()
{
    int m,n,a,b,set[205];
    bool flag;
    while(~scanf("%d%d",&n,&m))
    {
        flag=false;
        ini();
        memset(set,0,sizeof(set));
        memset(map,0,sizeof(map));
        while(m--)
        {
            scanf("%d%d",&a,&b);
            map[a][b]=1;map[b][a]=1;
            if(flag)
                continue;
            if(find(a)==find(b))
                flag=true;
            if(set[a]==0)
                set[a]=b;
            else
            {
                int x=find(set[a]);
                int y=find(b);
                if(x!=y)
                    father[x]=y;
            }
            if(set[b]==0)
                set[b]=a;
            else
            {
                int x=find(set[b]);
                int y=find(a);
                if(x!=y)
                    father[x]=y;
            }
        }
        if(flag)
            printf("No\n");
        else
            printf("%d\n",MMG(n)/2);
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值