POJ 2777 Count Color


  
  
Count Color
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 35691 Accepted: 10762

Description

Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem.  There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment with only one color. We can do following two operations on the board:  1. "C A B C" Color the board from segment A to segment B with color C.  2. "P A B" Output the number of different colors painted between segment A and segment B (including).  In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the beginning, the board was painted in color 1. Now the rest of problem is left to your. 

Input

First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operation defined previously.

Output

Ouput results of the output operation in order, each line contains a number.

Sample Input

2 2 4
C 1 1 2
P 1 2
C 2 2 2
P 1 2

Sample Output

2
1

Source

解题思路:注意到颜色一共只有30种,把每个区间内的颜色情况压缩成一个数,合并的时候两个数或一下,最终求大区间的那个数二进制位上有几个1即可
#include<iostream>
#include<cstdio>
#include<cstring>
#define Max 100005
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
using namespace std;
struct
{
	bool cover;
	int color;
}tree[Max<<2];
void push_down(int rt)
{
	if(tree[rt].cover)
	{
		tree[rt<<1].color=tree[rt].color;
	    tree[rt<<1].cover=true;
		tree[rt<<1|1].color=tree[rt].color;
		tree[rt<<1|1].cover=true;
		tree[rt].cover=false;
	}
}
void push_up(int rt)
{
	tree[rt].color=(tree[rt<<1].color|tree[rt<<1|1].color);
}
void build(int l,int r,int rt)
{
	tree[rt].cover=true;
	tree[rt].color=1;
	if(l==r)
		return ;
	int m=(l+r)>>1;
	build(lson);
	build(rson);
}
void update(int L,int R,int c,int l,int r,int rt)
{
	if(L<=l&&R>=r)
	{
		tree[rt].color=c;
		tree[rt].cover=true;
		return ;
	}
	push_down(rt);
	int m=(l+r)>>1;
	if(L<=m)
	    update(L,R,c,lson);
	if(R>m)
	    update(L,R,c,rson);
	push_up(rt);
}
void query(int L,int R,int &sum,int l,int r,int rt)
{
	if((L<=l&&r<=R)||(tree[rt].cover))
	{
		sum|=tree[rt].color;
		return ;
	}
	push_down(rt);
	int m=(l+r)>>1;
	if(L<=m)
		query(L,R,sum,lson);
	if(R>m)
		query(L,R,sum,rson);
}
int Solve(int sum){
    int ans=0;
    while(sum){
        if(sum&1)
            ans++;
        sum>>=1;
    }
    return ans;
}
int main()
{
	int i,n,t,o,a,b,c;
	char op[3];
	while(~scanf("%d%d%d",&n,&t,&o))
	{
		build(1,n,1);
		while(o--)
		{
			scanf("%s",op);
			if(op[0]=='C')
			{
				scanf("%d%d%d",&a,&b,&c);
				if(a>b)
					swap(a,b);
				update(a,b,1<<(c-1),1,n,1);
			}
			else
			{
				scanf("%d%d",&a,&b);
				if(a>b)
					swap(a,b);
				int sum=0;
				query(a,b,sum,1,n,1);
				printf("%d\n",Solve(sum));
			}
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值