HDU 1595 find the longest of the shortest

find the longest of the shortest

Time Limit: 1000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1878    Accepted Submission(s): 656


Problem Description
Marica is very angry with Mirko because he found a new girlfriend and she seeks revenge.Since she doesn't live in the same city, she started preparing for the long journey.We know for every road how many minutes it takes to come from one city to another.
Mirko overheard in the car that one of the roads is under repairs, and that it is blocked, but didn't konw exactly which road. It is possible to come from Marica's city to Mirko's no matter which road is closed.
Marica will travel only by non-blocked roads, and she will travel by shortest route. Mirko wants to know how long will it take for her to get to his city in the worst case, so that he could make sure that his girlfriend is out of town for long enough.Write a program that helps Mirko in finding out what is the longest time in minutes it could take for Marica to come by shortest route by non-blocked roads to his city.
 

Input
Each case there are two numbers in the first row, N and M, separated by a single space, the number of towns,and the number of roads between the towns. 1 ≤ N ≤ 1000, 1 ≤ M ≤ N*(N-1)/2. The cities are markedwith numbers from 1 to N, Mirko is located in city 1, and Marica in city N.
In the next M lines are three numbers A, B and V, separated by commas. 1 ≤ A,B ≤ N, 1 ≤ V ≤ 1000.Those numbers mean that there is a two-way road between cities A and B, and that it is crossable in V minutes.
 

Output
In the first line of the output file write the maximum time in minutes, it could take Marica to come to Mirko.
 

Sample Input
  
  
5 6 1 2 4 1 3 3 2 3 1 2 4 4 2 5 7 4 5 1 6 7 1 2 1 2 3 4 3 4 4 4 6 4 1 5 5 2 5 2 5 6 5 5 7 1 2 8 1 4 10 2 3 9 2 4 10 2 5 1 3 4 7 3 5 10
 

Sample Output
  
  
11 13 27
 

Author
ailyanlu
 

Source
解题思路:求给定的无向图中在某一条边被删去的情况下的最短路的最大值,先做一次spfa,记录下路径上的边,显然删边是这条路径上的边,枚举一下就好
#include<cstdio>
 #include<queue>
 #include<algorithm>
 using namespace std;
 const int maxn = 1005;
 const int maxm = 1005*500;
 const int inf = 9999999;
 struct node{
     int u,val,next;
 }edge[ maxm*2 ];
 int head[ maxn ],cnt;
 int dis[ maxn ],vis[ maxn ],path[ maxn ];
 int n,m,CNT;
 struct node22{
     int x,y;
 }road[ maxn ];
 int mat[ maxn ][ maxn ];
 void init(){
     cnt=0;
     CNT=0;
     memset( path,-1,sizeof(path) );
     memset( head,-1,sizeof( head ));
 }
 void addedge( int a,int b,int c ){
     edge[ cnt ].u=b;
     edge[ cnt ].val=c;
     edge[ cnt ].next=head[ a ];
     head[ a ]=cnt++;
 }
 void changeit(const int &x, const int &y, int va)  
 {  
     for( int i=head[x];i!=-1;i=edge[i].next ){
         if( edge[i].u==y ){
             edge[i].val=va;
         }
     }
 }  
 
 void spfa( int s ){
     for( int i=1;i<=n;i++ ){
         dis[i]=inf;
         vis[i]=0;
         //path[i]=s;
     }
     queue<int>q;
     while( !q.empty() )
         q.pop();
     vis[s]=1;
     dis[s]=0;
     q.push( 1 );
     while( !q.empty() ){
         int now=q.front();
         q.pop();
         vis[ now ]=0;
         for( int i=head[ now ];i!=-1;i=edge[i].next ){
             int next=edge[i].u;
             if( dis[next]>dis[now]+edge[i].val ){
                 dis[next]=dis[now]+edge[i].val;
                 path[next]=now;
                 if( vis[next]==0 ){
                     vis[next]=1;
                     q.push(next);
                 }
             }
         }
     }
     return ;
 }
 
 int main(){
     while( scanf("%d%d",&n,&m)!=EOF ){
         int a,b,c;
         init();
         while( m-- ){
             scanf("%d%d%d",&a,&b,&c);
             addedge( a,b,c );
             addedge( b,a,c );
             mat[a][b]=mat[b][a]=c;
         }
         spfa( 1 );
         for( int i=n;i!=1;i=path[i] ){
             road[ CNT ].x=i;
             road[ CNT ].y=path[i];
             CNT++;
         }
         int ans=0;
         for(int i = 0; i < CNT; i++){  
             changeit(road[i].x, road[i].y, inf);  
             changeit(road[i].y, road[i].x, inf);   
             spfa(1);  
             if(dis[n] > ans&&dis[n]!=inf) ans = dis[n];  
             changeit(road[i].x, road[i].y, mat[road[i].x][road[i].y]);  
             changeit(road[i].y, road[i].x, mat[road[i].x][road[i].y]);  
         }  
         printf("%d\n", ans);
     }
     return 0;
 }


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值