POJ 3259 Wormholes

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 21895 Accepted: 7808

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N,M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps toF (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Source

USACO 2006 December Gold

解题思路:在给定的图中,路径是双向的,虫洞是单向的,问是否可以从某一点出发,经过虫洞回到之前的某一个时间,看到之前的自己。很科幻的一道题,其实就是问是否在图中存在一个负权环。用Bellman_Ford算法或是SPFA算法均可。做的时候只要假设从1号点出发即可,因为只要图是连通的,从任一顶点出发效果是一样的。还有需要注意本题存在重边,因此用邻接矩阵保存图的话,一定要保存最大的那一条边。

#include<iostream>
using namespace std;
#define edge_max 5205
#define point_max 505
#define max 10010;
int x[edge_max],y[edge_max],w[edge_max];
int d[point_max];
int edge_num,N,M,W;
bool Bellman_Ford()
{
	int i,j;
	bool flag;
	for(i=2;i<=N;i++)
		d[i]=max;//初始化到所有非原点顶点的距离为正无穷
	d[1]=0;
	for(i=1;i<N;i++)
		{
			flag=false;//若在某一轮中所有边都不需要松弛操作,证明已得到最短路径且若有负权环也已出现
			for(j=1;j<=edge_num;j++)
			if(d[x[j]]+w[j]<d[y[j]])
				{
					d[y[j]]=d[x[j]]+w[j];
					flag=true;
			    }
			if(!flag)//没有松弛操作则退出
				break;
	    }
	for(i=1;i<=edge_num;i++)
		if(d[x[i]]+w[i]<d[y[i]])//证明有负权环
			return false;
    return true;
}
int main()
{
	int i,j,k,t,S,E,T;
	cin>>t;
	while(t--)
	{
		k=0;
		cin>>N>>M>>W;
		for(i=1;i<=M;i++)
		{
			cin>>S>>E>>T;
			k++;
			x[k]=S;y[k]=E;w[k]=T;
			k++;
			x[k]=E;y[k]=S;w[k]=T;
		}
		for(j=1;j<=W;j++)
		{
			cin>>S>>E>>T;
			k++;
			x[k]=S;y[k]=E;w[k]=-T;
		}
		edge_num=k;
		if(!Bellman_Ford())
			cout<<"YES\n";
		else
			cout<<"NO\n";
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值