ANTS POJ 1852

Ants
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 25628 Accepted: 10074
Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.
Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.
Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.
Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191
Sample Output

4 8
38 207
题意 :n只蚂蚁以每秒1cm的速度在长为Lcm的杆子上爬行。蚂蚁到达杆子端点时就会掉落。蚂蚁不能同时给通过杆子,只能各自反向爬回去。对于每只蚂蚁我们知道它距离杆子左端点的距离X,但是不知道蚂蚁的朝向。请计算蚂蚁落下杆子所需要的最长时间和最短时间。
解题思路:很好想的是对于每一只蚂蚁枚举他的状态(有两个:向左向右)但是这是一个指数函数2的n次方可定会时间超限。
但是我们仔细想一想如果两只蚂蚁就算是相遇之后又会有什么不一样的吗?各自转向走回去,就相当于没有遇到,一只蚂蚁一直走到头,就可以认为每只蚂蚁都是独立运动的,这样就可以只考虑每只蚂蚁的用时,这时候时间复杂度就降到了O(n)。

#include <stdio.h>

const int MAX_N = 1e6 + 10;

int book[MAX_N];

int max (int a, int b) {
	return a > b ? a : b;
}

int min (int a, int b) {
	return a > b? b : a;
}

void solve(int n, int L) {
	int minT = 0;
	for (int i = 0; i < n; i++)
		minT = max(minT, min(book[i], L - book[i]));
	int maxT = 0;
	for (int i = 0; i < n; i++)
		maxT = max(maxT, max(book[i], L - book[i]));
	printf ("%d %d\n", minT, maxT);
}

int main() {
	int T; scanf ("%d", &T);
	while (T --) {
		int L, n;
		scanf ("%d %d", & L, &n);
		for (int i = 0; i < n; i++)
			scanf ("%d", &book[i]);
		solve(n, L);
	}
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值