杭电5240Exam

Exam

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1005    Accepted Submission(s): 499


Problem Description
As this term is going to end, DRD needs to prepare for his final exams.

DRD has  n  exams. They are all hard, but their difficulties are different. DRD will spend at least  ri  hours on the  i -th course before its exam starts, or he will fail it. The  i -th course's exam will take place  ei  hours later from now, and it will last for  li  hours. When DRD takes an exam, he must devote himself to this exam and cannot (p)review any courses. Note that DRD can review for discontinuous time. 

So he wonder whether he can pass all of his courses. 

No two exams will collide. 
 

Input
First line: an positive integer  T20  indicating the number of test cases.
There are T cases following. In each case, the first line contains an positive integer  n105 , and  n  lines follow. In each of these lines, there are 3 integers  ri,ei,li , where  0ri,ei,li109

 

Output
For each test case: output ''Case #x: ans'' (without quotes), where  x  is the number of test cases, and  ans  is ''YES'' (without quotes) if DRD can pass all the courses, and otherwise ''NO'' (without quotes). 

 

Sample Input
  
  
2 3 3 2 2 5 100 2 7 1000 2 3 3 10 2 5 100 2 7 1000 2
 

Sample Output
  
  
Case #1: NO Case #2: YES
 

Source
 

Recommend
We have carefully selected several similar problems for you:   5551  5550  5549  5548  5547 


贪心:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{
	int a;
	int b;
	int c;
}t[110000];
int cmp(node a,node b)
{
	return a.b < b.b ;
}
int i,j,k,l,m,n,help=1;
int main()
{
	scanf("%d",&k);
	while(k--)
	{
		scanf("%d",&l);
		memset(t,0,sizeof(t));
		t[0].a=t[0].b=t[0].c=0;
		for(i=1;i<=l;i++)
		scanf("%d%d%d",&t[i].a ,&t[i].b,&t[i].c );
		sort(t,t+l+1,cmp);
		int flag=1;
		int sum=0;
		for(i=0;i<=l;i++)
		{
			sum+=t[i].a ;
			if(t[i].b<sum)
			{
				flag=0;
				break;
			}
			//t[i].b=t[i].b-t[i-1].a-t[i-1].c ;
			sum=sum+t[i].c;
		}
		if(flag)
		printf("Case #%d: YES\n",help++);
		else
		printf("Case #%d: NO\n",help++);
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值