HDU5240——贪心——Exam

Problem Description
As this term is going to end, DRD needs to prepare for his final exams.

DRD has  n exams. They are all hard, but their difficulties are different. DRD will spend at least ri hours on the i-th course before its exam starts, or he will fail it. The i-th course's exam will take place ei hours later from now, and it will last for li hours. When DRD takes an exam, he must devote himself to this exam and cannot (p)review any courses. Note that DRD can review for discontinuous time. 

So he wonder whether he can pass all of his courses. 

No two exams will collide. 
 

 

Input
First line: an positive integer  T20 indicating the number of test cases.
There are T cases following. In each case, the first line contains an positive integer n105, and n lines follow. In each of these lines, there are 3 integers ri,ei,li, where 0ri,ei,li109

 

 

Output
For each test case: output ''Case #x: ans'' (without quotes), where  x is the number of test cases, and ans is ''YES'' (without quotes) if DRD can pass all the courses, and otherwise ''NO'' (without quotes). 

 

 

Sample Input
2 3 3 2 2 5 100 2 7 1000 2 3 3 10 2 5 100 2 7 1000 2
 

 

Sample Output
Case #1: NO Case #2: YES
 

 

Source
 

 

Recommend
We have carefully selected several similar problems for you:   5245  5244  5243  5242  5241 
 大意:很水的一道贪心题目,排个序,只是在那道将军士兵基础上把输出最短路改成判断而已。。。上海比赛的时候我竟然1个小时了才做出,,,毕竟第一次参赛手抖不是...
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int inf = 0x3f3f3f3f;
struct edge{
    int r,e,l;
}t[100010];
bool cmp(edge i,edge j)
{
    return i.e < j.e;
}
int main()
{
    int T,n,r,e,l;
    bool flag;
    scanf("%d",&T);
    for(int cas = 1; cas <= T;cas++){
        scanf("%d",&n);
        for(int i = 1; i <= n ;i++){
            scanf("%d%d%d",&t[i].r,&t[i].e,&t[i].l);
        }
        sort(t+1,t+n+1,cmp);
        int max1 = 0,max2 = inf;
        int m = 0;
         flag = false ;
        for(int i = 1; i <= n; i++){
            if(i == 1)
            m = t[i].r;
            else 
            m = max2 + t[i].r;
            if(m > t[i].e){
                flag = true;
                break;
            }
            max1 += t[i].r;
            max2 = min(max1+t[i].l,max2);
        }
    printf("Case #%d: ",cas);
    if(flag == false)
        printf("YES\n");
    else printf("NO\n");
    }
    return 0;
}
            

  

转载于:https://www.cnblogs.com/zero-begin/p/4532182.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值