Exam (贪心)

As this term is going to end, DRD needs to prepare for his final exams.

DRD has n exams. They are all hard, but their difficulties are different. DRD will spend at least ri hours on the i-th course before its exam starts, or he will fail it. The i-th course's exam will take place ei hours later from now, and it will last for li
hours. When DRD takes an exam, he must devote himself to this exam and cannot (p)review any courses. Note that DRD can review for discontinuous time.

So he wonder whether he can pass all of his courses.

No two exams will collide.
Input First line: an positive integer T20 indicating the number of test cases.
There are T cases following. In each case, the first line contains an positive integer n105, and n lines follow. In each of these lines, there are 3 integers ri,ei,li, where 0ri,ei,li109.

Output For each test case: output ''Case #x: ans'' (without quotes), where x is the number of test cases, and ans is ''YES'' (without quotes) if DRD can pass all the courses, and otherwise ''NO'' (without quotes).

Sample Input
2
3
3 2 2
5 100 2
7 1000 2
3
3 10 2
5 100 2
7 1000 2
Sample Output
Case #1: NO
Case #2: YES

题意:DRD一共有n门考试,在每门考试前必须先复习r小时,每门考试开始的时间是e时刻,考试将

持续l小时,DRG可以不连续复习多科,但是对于某一科的复习必须是连续的,问DRD能否通过

所有的考试。

思路:按考试先后顺序排序,先复习花时间较少的科目,保证有较多的科目通过

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N = 1e5+5;
struct node{
	int r;
	int a,b;
	bool operator <(const node other) const{
		if(a==other.a) return r<other.r;
		return a<other.a;
	}
}arr[N];
bool judge(int n){
	int now=0;
	for(int i=0;i<n;i++){
		if(now+arr[i].r>arr[i].a) return false;
		else now=arr[i].a+arr[i].b;
	}
	return true;
}
int main(){
    int T,Cas=0;
    scanf("%d",&T);
    while(T--){
    	int n;
    	scanf("%d",&n);
    	for(int i=0;i<n;i++)
    	   scanf("%d%d%d",&arr[i].r,&arr[i].a,&arr[i].b);
    	sort(arr,arr+n);
    	if(judge(n)) printf("Case #%d: YES\n",++Cas);
    	else printf("Case #%d: NO\n",++Cas);
	}
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值