【解题报告】uva116_Unidirectional TSP(单向TSP, dp)

16 篇文章 0 订阅
12 篇文章 0 订阅

116 - Unidirectional TSP

Time limit: 3.000 seconds



 Unidirectional TSP 

Background

Problems that require minimum paths through some domain appear in many different areas of computer science. For example, one of the constraints in VLSI routing problems is minimizing wire length. The Traveling Salesperson Problem (TSP) -- finding whether all the cities in a salesperson's route can be visited exactly once with a specified limit on travel time -- is one of the canonical examples of an NP-complete problem; solutions appear to require an inordinate amount of time to generate, but are simple to check.

This problem deals with finding a minimal path through a grid of points while traveling only from left to right.

The Problem

Given an tex2html_wrap_inline352 matrix of integers, you are to write a program that computes a path of minimal weight. A path starts anywhere in column 1 (the first column) and consists of a sequence of steps terminating in column n (the last column). A step consists of traveling from column i to column i+1 in an adjacent (horizontal or diagonal) row. The first and last rows (rows 1 and m) of a matrix are considered adjacent, i.e., the matrix ``wraps'' so that it represents a horizontal cylinder. Legal steps are illustrated below.

picture25

The weight of a path is the sum of the integers in each of the n cells of the matrix that are visited.

For example, two slightly different tex2html_wrap_inline366 matrices are shown below (the only difference is the numbers in the bottom row).

picture37

The minimal path is illustrated for each matrix. Note that the path for the matrix on the right takes advantage of the adjacency property of the first and last rows.

The Input

The input consists of a sequence of matrix specifications. Each matrix specification consists of the row and column dimensions in that order on a line followed by tex2html_wrap_inline376 integers where m is the row dimension and n is the column dimension. The integers appear in the input in row major order, i.e., the first n integers constitute the first row of the matrix, the second n integers constitute the second row and so on. The integers on a line will be separated from other integers by one or more spaces. Note: integers are not restricted to being positive. There will be one or more matrix specifications in an input file. Input is terminated by end-of-file.

For each specification the number of rows will be between 1 and 10 inclusive; the number of columns will be between 1 and 100 inclusive. No path's weight will exceed integer values representable using 30 bits.

The Output

Two lines should be output for each matrix specification in the input file, the first line represents a minimal-weight path, and the second line is the cost of a minimal path. The path consists of a sequence of nintegers (separated by one or more spaces) representing the rows that constitute the minimal path. If there is more than one path of minimal weight the path that is lexicographically smallest should be output.

Sample Input

5 6
3 4 1 2 8 6
6 1 8 2 7 4
5 9 3 9 9 5
8 4 1 3 2 6
3 7 2 8 6 4
5 6
3 4 1 2 8 6
6 1 8 2 7 4
5 9 3 9 9 5
8 4 1 3 2 6
3 7 2 1 2 3
2 2
9 10 
9 10

Sample Output

1 2 3 4 4 5
16
1 2 1 5 4 5
11
1 1
19



题目大意:

首先输入m和n,接下来输入一个m行n列的矩阵,每点的值代表该位置的花费。求从矩阵第一列的任意位置移动到最后一列的任意位置的最小花费及路径。若存在多条路径,输出字典序最小的。路径总花费为所经过的每点的花费的和,移动规则如下:
picture25


解题思路:

定义状态d(i,j),代表从坐标(i,j)移动到最后一列的最小花费。

状态转移方程:d(i,j) = min{ d(i-1,j+1), d(i,j), d(i+1,j) }

计算出所有状态后,再从第一列起点开始向后递推,打印出路径。注意要选择行号最小的点,使路径的字典序最小。


#include <cstdio>
#include <cstring>
#define _min(a,b) ( a<b?a:b )
#define min(a,b,c) ( _min(_min(a,b),c) )

int m,n;//行列数
int W[10][100];//m*n矩阵各点的值
int d[10][100];//状态d[i][j]代表从坐标(i,j)到达最后一列的最小花费

int main()
{
    //freopen("in.txt","r",stdin);
    while(~scanf("%d%d",&m,&n)){
        for(int i=0;i<m;++i){
            for(int j=0;j<n;++j) scanf("%d",&W[i][j]);
        }
        //初始化
        memset(d,0,sizeof(d));
        for(int i=0;i<m;++i) d[i][n-1]=W[i][n-1];

        for(int j=n-2;j>=0;--j){//从倒数第2列开始降序枚举列
            for(int i=0;i<m;++i){//枚举计算各行的状态
                d[i][j]=min(d[i][j+1], d[i-1==-1?m-1:i-1][j+1], d[(i+1)%m][j+1])+W[i][j];
            }
        }
        int res=d[0][0],i_r=0;//结果与起点行坐标
        for(int i=1;i<m;++i){
            if(d[i][0]<res) res=d[i][0],i_r=i;
        }
        //输出路径
        printf("%d",i_r+1);//起点
        for(int j=0;j<n-1;++j){//升序枚举列
            int v=d[i_r][j]-W[i_r][j];//后一个状态的值
            int i_r2=110;//保存最小行号
            if(d[i_r-1==-1?m-1:i_r-1][j+1]==v) i_r2=_min(i_r2, (i_r-1==-1?m-1:i_r-1) );
            if(d[i_r][j+1]==v) i_r2=_min(i_r2, i_r);
            if(d[(i_r+1)%m][j+1]==v) i_r2=_min(i_r2, (i_r+1)%m);
            printf(" %d",i_r2+1);
            i_r=i_r2;
        }
        printf("\n%d\n",res);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值