sicily 1231. The Embarrassed Cryptography

1231. The Embarrassed Cryptography

Constraints

Time Limit: 2 secs, Memory Limit: 32 MB

Description

The young and very promising cryptographer Odd Even has implemented the security module of a large system with thousands of users, which is now in use in his company. The cryptographic keys are created from the product of two primes, and are believed to be secure because there is no known method for factoring such a product effectively.
What Odd Even did not think of, was that both factors in a key should be large, not just their product. It is now possible that some of the users of the system have weak keys. In a desperate attempt not to be fired, Odd Even secretly goes through all the users keys, to check if they are strong enough. He uses his very poweful Atari, and is especially careful when checking his boss' key.

Input

The input consists of no more than 20 test cases. Each test case is a line with the integers 4 <= K <= 10100 and 2 <= L <= 106. K is the key itself, a product of two primes. L is the wanted minimum size of the factors in the key. The input set is terminated by a case where K = 0 and L = 0.

Output

For each number K, if one of its factors are strictly less than the required L, your program should output "BAD p", where p is the smallest factor in K. Otherwise, it should output "GOOD". Cases should be separated by a line-break.

Sample Input

143 10
143 20
667 20
667 30
2573 30
2573 40
0 0

Sample Output

GOOD
BAD 11
GOOD
BAD 23
GOOD
BAD 31

题目分析

给定一个大整数和num,看大整数能否被比num小的素数整除
大整数除法,利用同余定理

#include <stdio.h>
#include <memory.h>
int prime[80000];
int count;

void init() {
  int visited[1000005];
  memset(visited, true, sizeof(visited));
  for (int c = 2; c < 1000005; ++c)
    if (visited[c])
      for (int d = c + c; d < 1000005; d += c)
        visited[d] = false;

  count = 0;
  for (int c = 2; c < 1000005; ++c)
    if (visited[c])
      prime[count++] = c;
}

int main()
{
  init();
  char key[101];
  int test;
  while (scanf("%s%d", key, &test)) {
    if (key[0] == '0' && test == 0)
      break;

    int hope = 0;
    for (int c = 0; prime[c] < test; ++c) {
      int temp = 0;
      for (int d = 0; d < strlen(key); ++d) {
        temp = (temp * 10) + (key[d] - '0');
        temp %= prime[c];
      }

      if (temp == 0) {
        hope = prime[c];
        break;
      }
    }
    if (hope)
      printf("BAD %d\n", hope);
    else
      printf("GOOD\n");
  }

  return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值