PTA甲级 1113 Integer Set Partition (25 point(s))

强烈推荐,刷PTA的朋友都认识一下柳神–PTA解法大佬

本文由参考于柳神博客写成

柳神的CSDN博客,这个可以搜索文章

柳神的个人博客,这个没有广告,但是不能搜索

还有就是非常非常有用的 算法笔记 全名是

算法笔记  上级训练实战指南		//这本都是PTA的题解
算法笔记

PS 今天也要加油鸭

在这里插入图片描述

题目原文

Given a set of N (>1)

ositive integers, you are supposed to partition them into two disjoint sets A1 and A2 of n1 and n2 numbers, respectively. Let S1 and S2 denote the sums of all the numbers in A1 and A2, respectively. You are supposed to make the partition so that ∣n1−n2∣ is minimized first, and then ∣S1−S2∣ is maximized.

Input Specification:

Each input file contains one test case. For each case, the first line gives an integer N (2≤N≤105), and then N positive integers follow in the next line, separated by spaces. It is guaranteed that all the integers and their sum are less than 231.

Output Specification:

For each case, print in a line two numbers: ∣n1−n2∣ and ∣S1−S2∣, separated by exactly one space.

Sample Input 1:

10
23 8 10 99 46 2333 46 1 666 555

Sample Output 1:

0 3611

Sample Input 2:

13
110 79 218 69 3721 100 29 135 2 6 13 5188 85

Sample Output 2:

1 9359

生词如下:

PS:这题太水了.水到无法呼吸. 但是就这样.题目我还是看不懂

虽然写出来了-但是因为这个水题啊.

disjoint 不相交

题目大意:

#include <iostream>
#include <map>
#include <cstdio>
#include <set>
#include<vector>
#include<algorithm>
using namespace std;
int main() {
    int N;
    cin >> N;
    vector<int> Data(N);
    int n1=0, n2=0,sum1=0,sum2=0; 
    for (int i = 0; i < N; ++i) {
        int j = 0;
        scanf("%d", &j);
        Data[i] = j;
    }
    sort(Data.begin(), Data.end());
    n1 = N / 2;
    n2 = N - n1;                //大的那个
    printf("%d", n2 - n1);
    for (int i = 0; i < N; ++i) {
        if (i < n1) sum1 += Data[i];
        else    sum2 += Data[i];
    }
    printf(" %d", sum2 - sum1);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值