PTA甲1124 Raffle for Weibo Followers (20 point(s))

强烈推荐,刷PTA的朋友都认识一下柳神–PTA解法大佬

本文由参考于柳神博客写成

柳神的CSDN博客,这个可以搜索文章

柳神的个人博客,这个没有广告,但是不能搜索

还有就是非常非常有用的 算法笔记 全名是

算法笔记  上级训练实战指南		//这本都是PTA的题解算法笔记

PS 今天也要加油鸭

在这里插入图片描述

题目原文

John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo – that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers M (≤ 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John’s post.

Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

Output Specification:

For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print Keep going... instead.

Sample Input 1:

9 3 2
Imgonnawin!
PickMe
PickMeMeMeee
LookHere
Imgonnawin!
TryAgainAgain
TryAgainAgain
Imgonnawin!
TryAgainAgain

Sample Output 1:

PickMe
Imgonnawin!
TryAgainAgain

Sample Input 2:

2 3 5
Imgonnawin!
PickMe

Sample Output 2:

Keep going...

生词如下:

意思还是比较简单的,就是简单的

Faffle 抽奖

candidate 候选人

题目大意:

就是一个人抽奖,抽个粉丝,从S个人开始,N个间隔,抽中的下一位.

思路如下:

用一个set集合,因为set有自动去重功能,然后find一下就差不多了,简单的送分题

代码如下:

#include<iostream>
#include<vector>
#include<string.h>
#include<set>
using namespace std;
int main(void) {
	set<string> Data;
	set<string> Win;
	bool first=false;
	int M=0, N, S,Ncopy;
	cin >> M >> N >> S;
	Ncopy = N;
	for (int i = 0; i < M; ++i) {
		string t;
		cin >> t;
		Data.insert(t);
		if (i == S - 1&&!first) {
			Win.insert(t);
			cout << t << endl;
			first = true;
		}
		else if (first) {
			Ncopy--;
			if (Ncopy == 0&&Win.find(t)==Win.end()) {
				cout << t << endl;
				Ncopy = N;
				Win.insert(t);
			}
			else if (Ncopy == 0 && Win.find(t) != Win.end()) {
				Ncopy++;
			}
		}
	}
	if (!first) {
		cout << "Keep going...";
	}
	return 0;
}

我感觉柳神的代码有点问题,所以我不放上来了,有兴趣的自己去看吧

给个眼

柳神博客

有兴趣就自己去看吧.map用的还是极好的.

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值