STL初步:映射map(反片语(Ananagrams))

map就是从键(key)到值(value)的映射。
例如可以用一个map<string,int>month_name来表示“月份名字到月份编号”的映射,然后用month_name[“July”]=7这样的方式来赋值。
输入一些单词,找出所有满足如下条件的单词:该单词不能通过字母重排,得到输入文本中的另外一个单词。

在判断是否满足条件时,字母不分大小写,但在输入时应保留输入中的大小写,按字典序进行排列(所有大写字母在小写字母的前面)
样例输入:
ladder came tape soon leader acme RIDE lone Dreis peat ScAlE orb eye Rides dealer NotE derail LaCeS drIed
noel dire Disk mace Rob dries

样例输出:
Disk
NotE
derail
drIed
eye
ladder
soon

分析

把每个单词“标准化”,即全部转化为小写字母后再进行排序,然后放到map中进行统计。

#include <iostream>
#include<cstring>
#include<cctype>
#include<vector>
#include<map>
#include<algorithm>
using namespace std;
map <string,int> cnt;
vector<string> words;
//将单词s进行标准化 
string repr(const string &s)
{
    string ans = s;
    for(int i = 0;i < ans.length();i++)
    { 
        ans[i] = tolower(ans[i]);
    } 
    sort(ans.begin(),ans.end());
    return ans;
}
int main()
{
    int n = 0;
    string s;
    while(cin >> s)
    {
        if(s[0]=='#') 
  	{
   	    break;
  	} 
        words.push_back(s);
        string r = repr(s);
        if(!cnt.count(r)) 
  	{
   	    cnt[r]=0;
  	}
        cnt[r]++;
    }
    vector<string> ans;
    for(int i = 0;i < words.size();i++)
    { 
        if(cnt[repr(words[i])]==1)
        { 
            ans.push_back(words[i]);
        } 
        sort(ans.begin(),ans.end());
        for(int i = 0;i < ans.size();i++)
        { 
            cout << ans[i] << endl;
        }
    } 
    return 0;
}

注:set头文件和map头文件中的map分别是集合和映射。二者都支持insert,find,count和remove操作,并且可以按照从小到大的顺序循环遍历其中的元素。map还提供了"[]"运算符,使map可以像数组一样使用。map也称作关联数组。

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

【执珪】瑕瑜·夕环玦

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值