UVA 1584 - Circular Sequence(环状序列)(字典序)

1584 - Circular Sequence

Time limit: 3.000 seconds

Some DNA sequences exist in circular forms as in the following figure, which shows a circular sequence ``CGAGTCAGCT", that is, the last symbol ``T" in ``CGAGTCAGCT" is connected to the first symbol ``C". We always read a circular sequence in the clockwise direction.

\epsfbox{p3225.eps}

Since it is not easy to store a circular sequence in a computer as it is, we decided to store it as a linear sequence. However, there can be many linear sequences that are obtained from a circular sequence by cutting any place of the circular sequence. Hence, we also decided to store the linear sequence that is lexicographically smallest among all linear sequences that can be obtained from a circular sequence.

Your task is to find the lexicographically smallest sequence from a given circular sequence. For the example in the figure, the lexicographically smallest sequence is ``AGCTCGAGTC". If there are two or more linear sequences that are lexicographically smallest, you are to find any one of them (in fact, they are the same).

Input 

The input consists of T test cases. The number of test cases T is given on the first line of the input file. Each test case takes one line containing a circular sequence that is written as an arbitrary linear sequence. Since the circular sequences are DNA sequences, only four symbols, ACG and T, are allowed. Each sequence has length at least 2 and at most 100.

Output 

Print exactly one line for each test case. The line is to contain the lexicographically smallest sequence for the test case.

The following shows sample input and output for two test cases.

Sample Input 

2                                     
CGAGTCAGCT                            
CTCC

Sample Output 

AGCTCGAGTC 
CCCT
  题目大意:给你一个环状字符串,你可以从任意起点开始读,要求找出字典序最小的字符串。

  思路:从字符串的每一个字符str[i]开始读字符串,让它和上一个字典序最的比较,如果比上一个的字典序还小,那么就将minn更新为这个字符串的str[i]的i,然后继续比较。

  这个函数的实现比较相似,毕竟是相同的思路

函数:

bool findmin(int n,int m)//查看以谁为新的字符串起点字典序最小
{
    int len=strlen(str);
    for(int i=0;i<len;i++)
        if(str[(n+i)%len]!=str[(m+i)%len])
            return str[(n+i)%len]<str[(m+i)%len];
    return false;//相等的情况
}

完整程序:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char str[105];
bool findmin(int n,int m)//查看以谁为新的字符串起点字典序最小
{
    int len=strlen(str);
    for(int i=0;i<len;i++)
        if(str[(n+i)%len]!=str[(m+i)%len])
            return str[(n+i)%len]<str[(m+i)%len];
    return false;//相等的情况
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        cin>>str;
        int minn=0,len=strlen(str);
        for(int i=0;i<len;i++)//访问字符串的每一位
            if(findmin(i,minn)) minn=i;//更新为大字典序的位置
            for(int i=0;i<len;i++)
                printf("%c",str[(i+minn)%len]);
            printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值