HDU-5918 Sequence I(暴力)(KMP)

Sequence I

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 422    Accepted Submission(s): 158


Problem Description
Mr. Frog has two sequences   a1,a2,,an  and   b1,b2,,bm  and a number p. He wants to know the number of positions q such that sequence   b1,b2,,bm  is exactly the sequence   aq,aq+p,aq+2p,,aq+(m1)p  where   q+(m1)pn  and   q1 .
 

Input
The first line contains only one integer   T100 , which indicates the number of test cases.

Each test case contains three lines.

The first line contains three space-separated integers   1n106,1m106  and   1p106 .

The second line contains n integers   a1,a2,,an(1ai109) .

the third line contains m integers   b1,b2,,bm(1bi109) .
 

Output
For each test case, output one line “Case #x: y”, where x is the case number (starting from 1) and y is the number of valid q’s.
 

Sample Input
  
  
2 6 3 1 1 2 3 1 2 3 1 2 3 6 3 2 1 3 2 2 3 1 1 2 3
 

Sample Output
  
  
Case #1: 2 Case #2: 1
 

Source
  
  开始看见这个题,感觉复杂度挺模糊的,所以想暴力一发,然而自己写挫了,想了下将a数组拆开,感觉太麻烦了,就弃了,结果这两个做法都是可行的,第二种奇妙的可以用KMP,复杂度低多了。所以,有想法就要上!!!
1.暴力,直接枚举q,然后我是判断条件写挫了,看了别人的暴力好久才找到,竟然差点以为while和for有区别。 This
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
const int N = 1000005;
int a[N],b[N];

int main()
{
    int t,n,m,p;
    cin >> t;
    for(int ca = 1;ca <= t;ca++)
    {
        scanf("%d%d%d",&n,&m,&p);
        for(int i = 1;i <= n;i++)
            scanf("%d",&a[i]);
        for(int i = 1;i <= m;i++)
            scanf("%d",&b[i]);
        printf("Case #%d: ",ca);
        int sum = 0;
        for(int i = 1;i <= n && i+(m-1)*p <= n;i++)
        {
            int j = 0,r = i;
            while(a[r] == b[j+1])
            {
                j++;
                r = i + j*p;
                if(j >= m)
                {
                    sum++;
                    break;
                }
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}

2.KMP,可以将数组抽出来,也可以将kmp模板中的起点和++修改一下。
卧槽,貌似我以前写的kmp模板都是错的,,,
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int Next[2000100];
int a[2000100],b[2000100],c[2000100];
void Getfail(int m)
{
    int j, k;
    j = 0; k = -1; Next[0] = -1;
    while(j < m)
        if(k == -1 || b[j] == b[k])
            Next[++j] = ++k;
        else
            k = Next[k];

}
int KMP(int n,int m)
{
    int i = 0,j = 0,ans = 0;
    while(i < n)
    {
        if(j == -1 || c[i] == b[j])
        {
            i++,j++;
            if(j == m)
            {
                j = Next[j];
                ans++;
            }
        }
        else
            j = Next[j];
    }
    return ans;
}
int main()
{
    int t,n,m,p;
    cin >> t;
    for(int ca = 1;ca <= t;ca++)
    {
        scanf("%d%d%d",&n,&m,&p);
        for(int i = 0;i < n;i++)
            scanf("%d",&a[i]);
        for(int i = 0;i < m;i++)
            scanf("%d",&b[i]);
        printf("Case #%d: ",ca);
        int sum = 0;
        Getfail(m);
        for(int i = 0;i < p;i++)
        {
            int num = 0;
            for(int j = i;j < n && i+(m-1)*p < n;j += p)
                c[num++] = a[j];
            sum += KMP(num,m);
        }
        printf("%d\n",sum);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值