HDU5918-Sequence I(KMP)

63 篇文章 0 订阅
16 篇文章 0 订阅

Sequence I

                                                                          Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
                                                                                                        Total Submission(s): 444    Accepted Submission(s): 168

Problem Description
Mr. Frog has two sequences  a1,a2,,an  and  b1,b2,,bm  and a number p. He wants to know the number of positions q such that sequence  b1,b2,,bm  is exactly the sequence  aq,aq+p,aq+2p,,aq+(m1)p  where  q+(m1)pn  and  q1 .
 
Input
The first line contains only one integer  T100 , which indicates the number of test cases.

Each test case contains three lines.

The first line contains three space-separated integers  1n106,1m106  and  1p106 .

The second line contains n integers  a1,a2,,an(1ai109) .

the third line contains m integers  b1,b2,,bm(1bi109) .
 
Output
For each test case, output one line “Case #x: y”, where x is the case number (starting from 1) and y is the number of valid q’s.
 
Sample Input
  
  
2 6 3 1 1 2 3 1 2 3 1 2 3 6 3 2 1 3 2 2 3 1 1 2 3
 
Sample Output
  
  
Case #1: 2 Case #2: 1
 
Source

题意:给定序列a、序列b和整数p,求有多少个k使得b1、b2、b3……bm恰好是ak、ak+p、ak+2p、……ak+(m-1)p

解题思路:KMP变形


#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>

using namespace std;

int a[1000900],b[1000090];
int nt[1000090],n,m,p,sum;

void get_next()
{
    nt[0]=-1;
    for(int i=0; i<m; i++)
    {
        int k=nt[i];
        while(k>=0&&b[i]!=b[k])
            k=nt[k];
        nt[i+1]=k+1;
    }
}

void kmp(int x)
{
    int i=x,j=0;
    while(i<n)
    {
        if(a[i]==b[j]||j==-1)
            i+=p,j++;
        else
            j=nt[j];
        if(j>=m) sum++,j=nt[j];
    }
}

int main()
{
    int t,cas=0;
    scanf("%d",&t);
    while(t--)
    {
        sum=0;
        scanf("%d %d %d",&n,&m,&p);
        for(int i=0; i<n; i++)
            scanf("%d",&a[i]);
        for(int i=0; i<m; i++)
            scanf("%d",&b[i]);
        if(m>n)
        {
            printf("Case #%d: 0\n",++cas);
            continue;
        }
        get_next();
        for(int i=0; i<p; i++)
            kmp(i);
        printf("Case #%d: %d\n",++cas,sum);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值