1122 Hamiltonian Cycle (25point(s)) - C语言 PAT 甲级

1122 Hamiltonian Cycle (25point(s))

The “Hamilton cycle problem” is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a “Hamiltonian cycle”.

In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format Vertex1 Vertex2, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

n V​1​​ V​2​​ … V​n​​

where n is the number of vertices in the list, and V​i​​’s are the vertices on a path.

Output Specification:

For each query, print in a line YES if the path does form a Hamiltonian cycle, or NO if not.

Sample Input:

6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1

Sample Output:

YES
NO
NO
NO
YES
NO

题目大意:

输入一个图,判断所给路径是否为图的一个哈密顿环

设计思路:

哈密顿环必须同时满足以下条件:

  1. 构成一个环路
  2. 经过图中的所有节点
  3. 除首尾节点为同一节点出现两次,其他节点只能出现一次

针对其特点,写一个判断函数即可

编译器:C (gcc)
#include <stdio.h>

int v[210][210];

int judge(int *p, int cnt, int n)
{
        if (cnt != n + 1 || p[0] != p[cnt - 1])
                return 0;
        int i, j;
        for (i = 1; i < cnt; i++)
                for (j = i + 1; j < cnt; j++)
                        if (p[i] == p[j])
                                return 0;
        for (i = 1; i < cnt; i++)
                if (v[p[i -1]][p[i]] == 0)
                        return 0;
        return 1;
}

int main(void)
{
        int n, m, k;
        int i, a, b;
        int p[410];

        scanf("%d%d", &n, &m);
        while (m--) {
                scanf("%d%d", &a, &b);
                v[a][b] = 1;
                v[b][a] = 1;
        }
        scanf("%d", &k);
        while (k--) {
                scanf("%d", &m);
                for (i = 0; i < m; i++)
                        scanf("%d", &p[i]);
                printf("%s\n", judge(p, m, n) ? "YES" : "NO");
        }
        return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值