Suppose there are M people, including you, playing a special card game. At the beginning, each player receives N cards. The pip of a card is a positive integer which is at most N*M. And there are no two cards with the same pip. During a round, each player chooses one card to compare with others. The player whose card with the biggest pip wins the round, and then the next round begins. After N rounds, when all the cards of each player have been chosen, the player who has won the most rounds is the winner of the game.
Given your cards received at the beginning, write a program to tell the maximal number of rounds that you may at least win during the whole game.
Input
The input consists of several test cases. The first line of each case contains two integers m (2?20) and n (1?50), representing the number of players and the number of cards each player receives at the beginning of the game, respectively. This followed by a line with n positive integers, representing the pips of cards you received at the beginning. Then a blank line follows to separate the cases.
The input is terminated by a line with two zeros.
Output
For each test case, output a line consisting of the test case number followed by the number of rounds you will at least win during the game.
Sample Input
2 5 1 7 2 10 9 6 11 62 63 54 66 65 61 57 56 50 53 48 0 0
Sample Output
Case 1: 2 Case 2: 4
题意:有m个人每个人有n张牌,牌的大小是从1到n*m;给出自己的n张牌,问至少可以赢几次。
思路:先将自己的n张牌从大到小排序,将剩余的牌中最大的与自己的牌比较,如果自己的大就可以赢一次,如果自己的小,找到下一个大的牌继续比较。最后得到自己可以赢几次。
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;
bool cmp(int a,int b)
{
return a>b;
}
int main()
{
int m,n,s[55],book[1010],k=1;
while(scanf("%d%d",&m,&n)&&(m||n))
{
int i;
memset(book,0,sizeof(book));
for(i=0; i<n; i++)
{
scanf("%d",&s[i]);
book[s[i]]=1;//标记自己有的牌;
}
sort(s,s+n,cmp);//从大到小排序;
int a=n*m,sum=0;
while(book[a])
a--; //找到除了自己的牌的最大的一张牌;
for(i=0;i<n;i++)
{
if(s[i]>a)
sum++;//至少赢得局数加1;
else
{
book[a]=1;
while(book[a])
a--; //找到下一个最大的牌;
}
}
printf("Case %d: %d\n",k++,sum);
}
return 0;
}