1031. Hello World for U (20)

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, “helloworld” can be printed as:

h d
e l
l r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.
Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:
helloworld!
Sample Output:
h !
e d
l l
lowor
先计算出n1 和n3的值, 条件已经给好了, 需要比n2小,故通过循环计算出n1的值,然后就是分模块输出。

//
//  main.cpp
//  U_Hello_world
//
//  Created by Hui Du on 2017/10/11.
//  Copyright © 2017年 Hui Du. All rights reserved.
//

#include <iostream>
#include <string.h>
using namespace std;

int cal_max(int n){
    int max, n1;
    max = 0;
    for(int i = 3; i <= n; i++){
        n1 = (n+2-i)/2;
        if(n1 >= max && n1 <= i){
            max = n1;
        }
    }
    return max;
}
void print_space(int n){
    for(int i = 0; i < n; i++){
        printf(" ");
    }
}

int main(int argc, const char * argv[]) {
    int N, n1, n3, n2;
    string str;
    cin >> str;
    N = (int) str.length();
    n1 = cal_max(N);
    //cout << "max: " << n1 << endl;
    n3 = n1;
    n2 = N+2-2*n1;

    for(int i = 0; i < n1-1; i++){
        printf("%c",str[i]);
        print_space(n2-2);
        printf("%c\n",str[N-1-i]);
    }
    for(int i = n1-1; i<n1-1+n2;i++){
        printf("%c", str[i]);
    }
    putchar('\n');
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值