Pat(A) 1093. Count PAT's (25)

原题目:

原题链接:https://www.patest.cn/contests/pat-a-practise/1093

1093. Count PAT’s (25)


The string APPAPT contains two PAT’s as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT’s contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 105 characters containing only P, A, or T.

Output Specification:

For each test case, print in one line the number of PAT’s contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:
APPAPT
Sample Output:
2

题目大意

给定一个只包含P、A、T的字符串,求出子串为“PAT”的个数。

解题报告

利用排列组合的方法,对于任意一个A,假如其前面有m个P,后面有n个T,那么以这个A为中心形成的PAT个数为mn个。统计所有的即可,P[i]表示第i个字符前有几个P,T[i]表示第i个字符后有几个T。
注意要取模1000000007。

代码

#include "iostream"
#include "string"
using namespace std;

string s;
long long P[100000 + 5];
long long T[100000 + 5];
long long ans = 0;

void init(){
    cin>>s;
    int i;
    P[0] = 0;
    for(i = 1; i < s.length(); i++){
        P[i] = (s[i-1] == 'P')?P[i - 1] + 1:P[i - 1];
    }
    T[s.length() - 1] = 0;
    for(i = s.length() - 2; i >= 0; i--){
        T[i] = (s[i+1] == 'T')?T[i + 1] + 1:T[i + 1];
    }
}

void cal(){
    int i;
    for(i = 1; i < s.length() - 1; i++){
        if(s[i] == 'A')
            ans += P[i] * T[i] % 1000000007;
    }
}

int main(){
    init();
    cal();
    cout<<ans % 1000000007<<endl;
    system("pause");
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值