PAT(A) 1063. Set Similarity (25)

原题目:

原题链接:https://www.patest.cn/contests/pat-a-practise/1063

1063. Set Similarity (25)


Given two sets of integers, the similarity of the sets is defined to be Nc/Nt*100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specificatio

Each input file contains one test case. Each case first gives a positive integer N (<=50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (<=104) and followed by M integers in the range [0, 109]. After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:
3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3
Sample Output:
50.0%
33.3%

题目大意

对于任意两个集合,求NC/NT * 100% 的值,NC为两个集合共有的不重复数字个数,NT为两个集合各自不重复数字之和。
先输入N和集合,再给K个计算的。

解题报告

输入后集合后,对每个集合进行排序,去重。
计算时,判断两个集合共有的数个数,再计算即可。

代码

/*
* Problem: 1063. Set Similarity (25)
* Author: HQ
* Time: 2018-03-07
* State: Done
* Memo:
*/
#include "iostream"
#include "algorithm"
#include "vector"
using namespace std;
vector<int> str[50 + 5];
int N,K;

void distinct(vector<int> &a) {
    int i = 1, j = 1;
    for (; j < a.size(); j++) {
        if (a[j] != a[j - 1])
            a[i++] = a[j];
    }
    a.resize(i);
}

double cal(int x, int y) {
    int j = 0;
    int cou = 0;
    for (int i = 0; i < str[x].size(); i++) {
        for (; j < str[y].size(); j++) {
            if (str[x][i] == str[y][j]) {
                cou++;
                j++;
                break;
            }
            if (str[x][i] < str[y][j])
                break;
        }
    }
    return (double)cou / (str[x].size() + str[y].size() - cou);
}

int main() {
    cin >> N;
    int m;
    int x;
    for (int i = 0; i < N; i++) {
        cin >> m;
        for (int j = 0; j < m; j++) {
            cin >> x;
            str[i].push_back(x);
        }
        sort(str[i].begin(), str[i].end());
        distinct(str[i]);
    }
    cin >> K;
    int y;
    for (int i = 0; i < K; i++) {
        cin >> x >> y;
        printf("%.1f%%\n",cal(x-1,y-1) * 100);
    }
    system("pause");
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值