Pat(A) 1107. Social Clusters (30)

原题目:

原题链接:https://www.patest.cn/contests/pat-a-practise/1107

1107. Social Clusters (30)


When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A “social cluster” is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (<=1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

Ki: hi[1] hi[2] … hi[Ki]

where Ki (>0) is the number of hobbies, and hi[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4
Sample Output:
3
4 3 1

题目大意

每个人有多个爱好,拥有相同爱好的人为同一簇。问有多少簇人,按人数有大到小输出每个簇的人数。

解题报告

并查集的题目,将拥有同一爱好的人归为同一集合。
ans[i]表示以i为根的一簇的人数,ans[0]表示总的簇数。
pre[i]表示上一个有爱好i的人的编号。

代码

#include "iostream"
#include "vector"
#include "algorithm"
using namespace std;

int father[1001] = {0};
int pre[1001] = {0}; // pre[i] means the last person who has a hobby i
int N;
vector<int> ans;

int getF(int x){
    int a = x,t;
    while(x != father[x]){
        x = father[x];
    }
    while(a != father[a]){
        t = a;
        a = father[a];
        father[t] = x;
    }
    return x;
}

void Union(int a,int b){
    int fa = getF(a);
    int fb = getF(b);
    father[fb] = fa;
}

void init(){
    scanf("%d",&N);
    int i,k,j,x;
    ans.resize(N + 1,0);
    for(i = 0; i < 1001; i++)
        father[i] = i;
    for(i = 1; i <= N; i++){
        scanf("%d: ",&k);
        for(j = 0; j < k; j ++){
            scanf("%d",&x);
            if(pre[x] == 0)
                pre[x] = i;
            Union(i,getF(pre[x]));
        }
    }
}

void cal(){
    int  i,f;
    for(i = 1; i <= N; i++){
        f = getF(i);
        if( f == i)
            ans[0]++;
        ans[getF(i)] ++;
    }
    sort(ans.begin() + 1,ans.end());
}

int main(){
    init();
    cal();
    printf("%d\n",ans[0]);
    if(ans[0]){
        printf("%d",ans[ans.size() - 1]);
        for(int i = ans.size() - 2,k = 1; k < ans[0]; i--,k++)
            printf(" %d",ans[i]);
        printf("\n");
    }
    system("pause");;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值