POJ:1006--BIORHYTHM(生理周期计算)

6 篇文章 0 订阅


就是一个求重合的题,有点类似于公倍数的变种吧。

给你三个参数(三个生理周期的高峰期(”高潮“大笑)),三个生理周期各自不同,让你计算下一个三重”高潮“的下一次到来时间。

其实就是求公倍数的变种:起始位置可以不相同、不为零,重合的日期再做一下处理(减去给定的时间),最后输出。


原题如下:


Biorhythms
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 110700 Accepted: 34443

Description

Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is one peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper and concentration will be easier. 
Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give the number of days to the next occurrence of a triple peak. 

Input

You will be given a number of cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by a line in which p = e = i = d = -1.

Output

For each test case, print the case number followed by a message indicating the number of days to the next triple peak, in the form: 

Case 1: the next triple peak occurs in 1234 days. 

Use the plural form ``days'' even if the answer is 1.

Sample Input

0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1

Sample Output

Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.

Source


吐槽一下POJ的题(貌似还是比赛题?),很多规则弄的太蛋疼,捉摸不清,改过来改过去都不对。或者是我英语太差?

你好你翻译啊,官方翻译的不也就这个鸟样,乌龙很多,language点成简体中文。原文本来是within 21252days ,翻译完了是小于21252,“小于”和“不大于”意思可差远了,他下边给的sample output可是有21252的,这样看,还不如用机器翻译,直译也是不大于吧?!

另一个比较纠结的问题是:碰到 9 9 9 7这种输入,结果是2呢?还是21252+2 == 21254呢?题目可是提示说d可能小于p,i,e的~!那只能是2了



最后没“成功”的大体代码如下:

#include<stdio.h>
main(){
        int p,i,e,d;
        int triple = 0;
        unsigned int counter = 0;
        scanf("%d %d %d %d",&p,&i,&e,&d);//init
        while(!(p == -1 && i == -1 && e == -1 && d == -1)){
                triple = p > i ? p : (i > e ? i : e);
//              triple++;//triple donot equals to p,i,e~?!
                while(!(((triple - p) % 23 == 0) && ((triple - i) % 28 == 0) && ((triple - e) % 33 == 0))){
                        triple++;
                }
//add
                printf("Case %d: the next triple peak occurs in %d days.\n",++counter,((triple <= d ? triple+23 * 28 * 33 : triple ) - d));
                scanf("%d %d %d %d",&p,&i,&e,&d);//update
        }
}


总体思路是,先从p,i,e中找一个最大的,就让triple自增,直到刚好达到三个高峰重合。

碰到0 0 0 0 这种输入,做了输出判断,如果triple不大于d,就加21252,再减去d得到结果。

基本上样本输入和输出肯定能对上号,但是不知道他测试我程序是凭靠什么?也不给错误提示,就是个wrong answer。



基本功能都完成了,边界问题也反复尝试,貌似没有找到点上。


不知道这个题逻辑错在哪了,别人的方法不太一样——中国剩余理论,感觉数学遇到瓶颈了。







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值