ZOJ Problem Set - 1074 To the Max (最大和子矩阵 dp)

Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u
 

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

题意:把一个具有最大和的子矩阵作为最大子矩阵。


本题直接模拟是要超时的,需要用到动态规划算法。

设数组b表示数组a的i~j行,对应列元素的和。

然后对数组b计算最大子段和,这就将二维动态规划问题转化为了一维动态规划问题。


#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
int n,sum,f,max;
int b[20000];
int dp[150][150];

int main(){
    f=-10;
    cin>>n;
    for(int i=0;i<n;i++)
    {
        cin>>dp[i][j];
    }
    for(int k=0;k<n;k++)//行
    {
        memset(b,0,sizeof(b));
        for(int i=k;i<n;i++)//
        {
            for(int j=0;j<n;j++)//每行
                b[j]+=dp[i][j];
            
            for(int i=0;i<n;i++)
            {
                if(sum<0)
                    sum=b[i];
                else
                    sum+=b[i];
                if(max<sum)
                    max=sum;
            }
           if(f<max)
               f=max;
        }
    }
    cout<<f<<endl;
    return 0;
}

三重循环,算法时间复杂度为O(n^3).

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值