ZOJ Problem Set - 2104 Let the Balloon Rise(map)

7 篇文章 0 订阅

Let the Balloon Rise

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.


Input

Input contains multiple test cases. Each test case starts with a number N (0 < N < 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.


Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.


Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0


Sample Output

red
pink



Author:  WU, Jiazhi
Source:  Zhejiang Provincial Programming Contest 2004


题目大意:

输入n个气球颜色,输出颜色最多的


解题思路:

用STL模板中的map(key, value)来做很容易,key为颜色,当同一种颜色重复时,让value计数,然后将value值最大的那个key输出即可。


AC:

#include <cstdio>
#include <string>
#include <map>
#include <iostream>
using namespace std;

int main()
{
	int n;
	while(cin>>n && n)
	{
		map <string, int> Balloon;
		string s;
		for(int i=0; i<n; i++)
		{
			cin>>s;
			Balloon[s]++;
		}
		int iMax = 0;
		map <string, int>::iterator point, loc; //定义迭代器
		for(point=Balloon.begin(); point!=Balloon.end(); point++)
		{
			if(iMax<point->second)		//first指的是key,second指的是第二个value
			{
				iMax = point->second;
				loc = point;
			}
		}
		cout<<loc->first<<endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值