Tanning Salon

Tanning Salon

时间限制(普通/Java):3000MS/10000MS          运行内存限制:65536KByte
总提交:25            测试通过:17

描述

Tan Your Hide, Inc., owns several coin-operated tanning salons. Research has shown that if a customer arrives and there are no beds available, the customer will turn around and leave, thus costing the company a sale. Your task is to write a program that tells the company how many customers left without tanning.

输入

The input consists of data for one or more salons, followed by a line containing the number 0 that signals the end of the input. Data for each salon is a single line containing a positive integer, representing the number of tanning beds in the salon, followed by a space, followed by a sequence of uppercase letters. Letters in the sequence occur in pairs. The first occurrence indicates the arrival of a customer, the second indicates the departure of that same customer. No letter will occur in more than one pair. Customers who leave without tanning always depart before customers who are currently tanning. There are at most 20 beds per salon.

输出

For each salon, output a sentence telling how many customers, if any, walked away. Use the exact format shown below.

样例输入

2 ABBAJJKZKZ
3 GACCBDDBAGEE
3 GACCBGDDBAEE
1 ABCBCA
0

样例输出

All customers tanned successfully.
1 customer(s) walked away.
All customers tanned successfully.
2 customer(s) walked away.

#include<iostream>
using std::cin;
using std::cout;
using std::endl;
#include<map>
using std::map;
#include<vector>
using std::vector;
#include<cstdlib>

#define NOT_FINISH 0
#define FINISHED 1
#define WAITING 2
#define PROCESSING 3
#define FINISHED_WAITING 4
#define FINISHED_PROCESSING 5

#define MAX 100000

int main(void){
	unsigned int total;
	while (cin >> total, total){
		vector<char> line;
		map<char, unsigned int> status;
		unsigned int token = 0;
		unsigned int leave = 0;
		char list[MAX];
		cin >> list;
		for (char* it = list; *it != 0; ++it){
			switch (status[*it]){
			case NOT_FINISH:
				if (token == total){ line.push_back(*it); status[*it] = WAITING; }
				else{ status[*it] = PROCESSING; ++token; }
				break;
			case FINISHED:
				if (token == total){ line.push_back(*it); status[*it] = FINISHED_WAITING; }
				else{ status[*it] = FINISHED_PROCESSING; ++token; }
				break;
			case WAITING:
				for (vector<char>::iterator vit = line.begin(); vit != line.end(); ++vit){
					if (*vit == *it){line.erase(vit);status[*it] = NOT_FINISH;break;}
				}
				break;
			case PROCESSING:
				status[*it] = FINISHED;
				if (line.empty()){ --token; }
				else{ status[line.front()] = PROCESSING; line.erase(line.begin()); }
				break;
			case FINISHED_WAITING:
				for (vector<char>::iterator vit = line.begin(); vit != line.end(); ++vit){
					if (*vit == *it){line.erase(vit);status[*it] = FINISHED;break;}
				}
				break;
			case FINISHED_PROCESSING:
				status[*it] = FINISHED;
				if (line.empty()){ --token; }
				else{ status[line.front()] = PROCESSING; line.erase(line.begin()); }
				break;
			}
		}
		for (map<char, unsigned int>::const_iterator it = status.begin(); it != status.end(); ++it){
			if (it->second != FINISHED){ ++leave; }
		}
		if (leave == 0) {
			cout << "All customers tanned successfully." << endl;
		}
		else{
			cout << leave << " customer(s) walked away." << endl;
		}
	}
	return EXIT_SUCCESS;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值