PAT : 01-复杂度2. Maximum Subsequence Sum (25)

Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4
首先题目给的例子有坑,如果不好好看题的话就会认为输出的是最大子列和以及最大子列的开始和结束的下标,但其实输出的是最大子列的开始和结束的值
其次要注意特殊点,一个是数字全为负时,还有一个相当讨厌,是数列中最大值为0时,此时的输出不满足全负的条件,因此输出一定是0 0 0

#include <stdio.h>
#include <stdlib.h>

int main()
{
	int n;
	scanf("%d", &n);
	int *numList = (int *) malloc (n * sizeof(int));
	int i=0, maxnum=0, flag=0;
	for(i = 0; i < n; i++)
	{
		scanf("%d", &numList[i]);
		if(numList[i] >= 0)
			flag = 1;
		if(maxnum < numList[i])
			maxnum = numList[i];
	}

	if(flag == 0)
		printf("0 %d %d\n", numList[0], numList[n-1]);

	else if(maxnum == 0)
		printf("0 0 0\n");

	else
	{
		int maxvalue=0, res = 0;
		int laststart=numList[0],start,end;
		
		for(i = 0; i < n; i++)
		{
			res += numList[i];
			
			if(res < 0)
			{
				res = 0;
				laststart = numList[i+1];
			}
			
			if(maxvalue < res || maxvalue == 0 && res == 0)
			{
				maxvalue = res;
				end = numList[i];
				start = laststart;
			}
		}
		
		printf("%d %d %d\n", maxvalue, start, end);
	}
	
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值