【PAT甲级】1004 Counting Leaves (30 分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

【翻译】:输入N,M,分别代表树的节点数和非叶子节点总数,接下来的M行输入非叶子节点ID(两位数),k,孩子数,ID[1]......ID[k],孩子节点的ID,输入以0结尾,输出从根节点开始每一层孩子节点数,数据间有空格,行尾没有空格。

又是参考柳神的,确实很easy,就是用dfs,首先用vector构建数,然后用深搜搜每一层就好了。 

#include <iostream>
#include <algorithm>
#include <vector>
#define MAX 1000
using namespace std;
int ans[MAX];
int maxdep = -1;
vector<int> v[MAX];
void dfs(int index,int depth){
	if(v[index].size() == 0){
		ans[depth]++;
		maxdep = max(depth, maxdep);
		return;
	}
	for(int i = 0; i < v[index].size(); i++){
		dfs(v[index][i], depth + 1);
	}
}
int main(){
	int n,m,k,c,id;//n是树的节点数,m树中无叶子节点的节点数 
	cin>>n>>m;
	for(int i = 0; i < m; i++){
		cin>>id>>k;
		for(int j = 0; j < k; j++){
			cin>>c;
			v[id].push_back(c);
		}
	}
	dfs(1,0);
	cout<<ans[0];
	for(int i = 1; i <= maxdep; i++){
		cout<<" "<<ans[i];
	}	
	return 0;
} 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值