1013 Battle Over Cities (25分)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1 -city​2and city​1-city3 Then if city​1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2 -city​3
​​ .
Input Specification:
Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:
For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:
3 2 3
1 2
1 3
1 2 3

Sample Output:
1
0
0

解题思路:
看到题目第一眼,基本都知道这是个遍历数簇的题目,做起来不难,但是在做的过程中,出现了不少雷区。测试的最后一个用例始终显示超时。
在网上找了下,看到了其他人的的博客,才知道原来是cin与cout效率低导致的。改用scanf与printf后就测试通过了。有兴趣的可以去看下的文章
https://blog.csdn.net/cv_jason/article/details/81019874

#include<stdio.h>
#include<vector>
#include<algorithm>
using namespace std;
int visit[1003]={0};
int d[1003]={0};
int n,m,k,temp;
vector<int> G[1003];
void DFS(int x){
	visit[x]=true;
	for(int i=0;i<G[x].size();i++){
		if(!visit[G[x][i]])	DFS(G[x][i]);
	}
}
int main(){
	scanf("%d %d %d",&n,&m,&k);
	int x,y;
	for(int i=0;i<m;i++){
		scanf("%d %d",&x,&y);
		G[x].push_back(y);
		G[y].push_back(x);
	}
	for(int i=0;i<k;i++){
		scanf("%d",&temp);
		fill(visit,visit+n+1,0);
		visit[temp]=1;
		int num=0;
		for(int j=1;j<=n;j++){
			if(!visit[j]){
				DFS(j);
				num++;
			}
		}
		printf("%d\n",num-1);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值