PAT 甲级 1013 Battle Over Cities (25分)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1​​-city​2​​ and city​1​​-city​3​​. Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​-city​3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

 

这道题的翻译我真的看不懂啊。。。

Finally there is a line containing K numbers, which represent the cities we concern.

这句话的意思是进行k次查询,能用query类似的词语吗?,非得用个concern...,老子又不是来考英语的

还有一点: 我一直以为是丢失的城市是连续的,也就是说第二个丢是在第一个丢的基础上,这样就是丢了两个城市,而题目的意思是每次只丢一个,且相邻之间相互独立
#include<iostream>
#include<vector>
#include<cstring>
#include<queue>
using namespace std;

vector<int> g[1010];
int lost[1010],vis[1010];
queue<int> q;
int cnt,d;

void bfs(){
    while(!q.empty()){
        int t = q.front();
        q.pop();
        for (auto x:g[t]){
            if (x == d) continue;
            else if (vis[x] == 0){
                vis[x] = 1;
                q.push(x);
            }
        }
    }
}

int main(){

    int n,m,k,x,y;

    cin>>n>>m>>k;

    for (int i = 0; i < m; ++i){
        scanf("%d %d",&x,&y);
        g[x].push_back(y);
        g[y].push_back(x);
    }

    for (int i = 0; i < k; ++i){
        
        cin >> d;
        cnt = 0;
        memset(vis,0,sizeof vis);
        for (int j = 1; j <= n; ++j){
            if (j != d && vis[j] == 0){
                q.push(j);
                vis[j] = 1;
                bfs();
                cnt++;
            }
        }
        if (cnt)
            cout<<cnt - 1<<endl;
        else cout<<0<<endl;
    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值