POJ-2117 Electricity (割点[Tarjan])

Electricity
http://poj.org/problem?id=2117
Time Limit: 5000MS Memory Limit: 65536K
   

Description

Blackouts and Dark Nights (also known as ACM++) is a company that provides electricity. The company owns several power plants, each of them supplying a small area that surrounds it. This organization brings a lot of problems - it often happens that there is not enough power in one area, while there is a large surplus in the rest of the country. 

ACM++ has therefore decided to connect the networks of some of the plants together. At least in the first stage, there is no need to connect all plants to a single network, but on the other hand it may pay up to create redundant connections on critical places - i.e. the network may contain cycles. Various plans for the connections were proposed, and the complicated phase of evaluation of them has begun. 

One of the criteria that has to be taken into account is the reliability of the created network. To evaluate it, we assume that the worst event that can happen is a malfunction in one of the joining points at the power plants, which might cause the network to split into several parts. While each of these parts could still work, each of them would have to cope with the problems, so it is essential to minimize the number of parts into which the network will split due to removal of one of the joining points. 

Your task is to write a software that would help evaluating this risk. Your program is given a description of the network, and it should determine the maximum number of non-connected parts from that the network may consist after removal of one of the joining points (not counting the removed joining point itself). 

Input

The input consists of several instances. 

The first line of each instance contains two integers 1 <= P <= 10 000 and C >= 0 separated by a single space. P is the number of power plants. The power plants have assigned integers between 0 and P - 1. C is the number of connections. The following C lines of the instance describe the connections. Each of the lines contains two integers 0 <= p1, p2 < P separated by a single space, meaning that plants with numbers p1 and p2 are connected. Each connection is described exactly once and there is at most one connection between every two plants. 

The instances follow each other immediately, without any separator. The input is terminated by a line containing two zeros. 

Output

The output consists of several lines. The i-th line of the output corresponds to the i-th input instance. Each line of the output consists of a single integer C. C is the maximum number of the connected parts of the network that can be obtained by removing one of the joining points at power plants in the instance.

Sample Input

3 3
0 1
0 2
2 1
4 2
0 1
2 3
3 1
1 0
0 0

Sample Output

1
2
2

题目大意:给定一个无向图,求删除某一点后,剩余图中连通分量数的最大值?


用Tarjan算法算出原图的连通分量数 以及 删除每一点后,其所在的连通分量会形成的连通分量数

然后枚举每一点作为删除的点,取最大值即可


#include <cstdio>
#include <cstring>
#include <vector>

using namespace std;

const int MAXN=10005;

int n,m,num,ans,cnt;
int low[MAXN],dfn[MAXN],blocks[MAXN];//biocks[i]表示删掉i点后,能形成的连通块数
vector<int> g[MAXN];

void Tarjan(int u,int p) {
    dfn[u]=low[u]=++num;
    int v;
    for(int i=0;i<g[u].size();++i) {
        v=g[u][i];
        if(v!=p) {
            if(dfn[v]==0) {
                Tarjan(v,u);
                low[u]=min(low[u],low[v]);
                if(dfn[u]<=low[v])//删去点u后的连通分量数+1
                    ++blocks[u];
            }
            else if(dfn[v]<low[u])
                low[u]=dfn[v];
        }
    }
}

int main() {
    int s,e;
    while(scanf("%d%d",&n,&m),n!=0||m!=0) {
        for(int i=0;i<n;++i)
            g[i].clear();
        ans=num=cnt=0;
        while(m-->0) {
            scanf("%d%d",&s,&e);
            g[s].push_back(e);
            g[e].push_back(s);
        }

        for(int i=0;i<n;++i) {
            dfn[i]=0;
            blocks[i]=1;//默认删除点i后,其父亲节点存在一个连通分量
        }
        for(int i=0;i<n;++i) {
            if(dfn[i]==0) {
                ++cnt;//cnt表示连通分量数
                blocks[i]=0;//根结点无父亲结点,即其无父亲结点的连通分量
                Tarjan(i,-1);
            }
        }
        for(int i=0;i<n;++i)
            ans=max(ans,cnt-1+blocks[i]);//cnt-1表示除去i所在的连通分量后的连通分量数;blocks[i]表示i所在连通分量在删除i点后的连通分量数
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值