非空子集个数

A - A
Time Limit:1000MS     Memory Limit:131072KB     64bit IO Format:%I64d & %I64u

Description

soda has a set   with   integers  . A set is called key set if the sum of integers in the set is an even number. He wants to know how many nonempty subsets of   are key set.
 

Input

There are multiple test cases. The first line of input contains an integer    , indicating the number of test cases. For each test case: 

The first line contains an integer    , the number of integers in the set.
 

Output

For each test case, output the number of key sets modulo 1000000007.
 

Sample Input

      
      
4 1 2 3 4
 

Sample Output

      
      
0 1 3

7

首先要理解题意,注意细节,这道题的意思是一个集合S中有n个整数,求元素个数为偶数的非空子集有多少个,知道公式2^(n-1)(mod)-1;就很简单了

记得是要对1000000007取模!!

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
#include<stdio.h>
__int64 f(__int64 a,__int64 b,__int64 c)
{
	__int64 t=1;
	a=a%c;
	while(b>0)
	{
		if(b%2==1)
		t=t*a%c;
		b=b/2;
		a=a*a%c;
	}
	return t;
}
int main()
{
	int t;
	__int64 n;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%I64d",&n);
		printf("%I64d\n",f(2,n-1,1000000007)-1);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值