【POJ1905】

27 篇文章 0 订阅
15 篇文章 0 订阅
Expanding Rods
Time Limit:500MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

When a thin rod of length L is heated n degrees, it expands to a new length L' = (1+n*C)*L, where C is the coefficient of heat expansion.

When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment.

Your task is to compute the distance by which the center of the rod is displaced. That means you have to calculate h as in the picture.

Input

Input starts with an integer T (≤ 20), denoting the number of test cases.

Each case contains three non-negative real numbers: the initial length of the rod in millimeters L, the temperature change in degrees n and the coefficient of heat expansion of the material C. Input data guarantee that no rod expands by more than one half of its original length. All the numbers will be between 0 and 1000 and there can be at most 5 digits after the decimal point.

Output

For each case, print the case number and the displacement of the center of the rod in single line. Errors less than 10-6 will be ignored.

Sample Input

3

1000 100 0.0001

150 10 0.00006

10 0 0.001

Sample Output

Case 1: 61.3289915

Case 2: 2.2502024857

Case 3: 0

大致题意:

一根两端固定在两面墙上的杆 受热弯曲后变弯曲

求前后两个状态的杆的中点位置的距离

解法:弯曲后的长度::s=2* θ*r, sinθ=(1/2)*l/r,联立得s=l*θ/sinθ;  实际上弯曲后的长度是l1=(1+n*c)*l;对角度θ进行二分;0到π/2; 将mid带入计算出s与l1比较

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
#include<cstdio>
#include<cmath>
#define P acos(-1.0)//表示π
using namespace std;
int main()
{
	int t,test=1;
	scanf("%d",&t);
	while(t--)
	{
		double l,n,c;
		scanf("%lf%lf%lf",&l,&n,&c);
		double l1=(1+n*c)*l;
		int Size=100;
		double k=0.0,g=P/2.0;
		while(Size--)
		{
		double mid=(k+g)/2.0;
		if(l*mid/sin(mid)>l1)
		g=mid;
		else
	k=mid;	
		}
		printf("Case %d: %.7lf\n",test++,0.5*l/sin(k)-0.5*l/tan(k));//半径-!!
	}
	return 0;
 } 
设弦长为L0(即原长),弧长为L1=(1+n*C)*l0,目标值为h,半径为R,弧所对圆心角为2θ(弧度制)。
可以得到以下方程组:
圆的弧长公式:L1=2θR
三角函数公式:L0=2*R*sinθ,变换得θ=arcsin(L0/(2*R))
勾股定理:R^2=(R-h)^2+(0.5*L0)^2,变换得L0^2+4*h^2=8*h*R
合并①②式得到
L1=2*R*arcsin(L0/(2*R))
半径R可以由③式变换得到
R=(L0^2+4*h^2)/(8*h)
可以用二分枚举h的值,计算出R和L1,与题目中L1进行比较。
化简得
r=(4h^2+l^2)/(8*h);
s=2*r*arcsin(l/(2r))
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
#include <stdio.h>
#include <math.h>
int main()
{
    double L0,L1,N,C;
    double high,low,h,r,L2;
    int t,test=1;
    scanf("%d",&t);
    while (t--)
    {
	scanf("%lf%lf%lf",&L0,&N,&C);
        L1=(1+N*C)*L0;
        high=0.5*L0;
        low=0.0;
        int Size=100;
        while (Size--)
        {
            h=(high+low)/2;
            r=(L0*L0+4*h*h)/(8*h);
            L2=2*r*asin(L0/(2*r));
            if (L1<L2) high=h;
            else low=h;
        }
        h=(high+low)/2;
        printf("Case %d: %.7f\n",test++,h);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值