Alarm--找规律

1010 - Alarm

Time Limit:1s Memory Limit:128MByte

Submissions:289Solved:96

DESCRIPTION
Given a number sequence [3,7,22,45,116,...][3,7,22,45,116,...]. Please tell me the kk-th number.
INPUT
A number T (T<100)T (T<100) indicates the number of the input cases. Then for each case there only is one integer k (1k10000)k (1≤k≤10000).
OUTPUT
For each case, ouput the kk-th number of the sequence in one line.
SAMPLE INPUT
214
SAMPLE OUTPUT
345
1 3=2*2-1
2 7=3*3-2
3 22=5*5-3
4 45=7*7-4
用素数打表即可
#include<cstdio>
#include<cstring>
long long a[1000000],s[1000000];
int main()
{
	int t;
	scanf("%d",&t);
	memset(a,0,sizeof(a));
	int k=1;
	for(int i=2;i<=1000000;i++)
	{
		if(a[i]==0)
		{
			s[k++]=i;
		for(int j=2*i;j<=1000000;j+=i)
		a[j]=1;
		}
		
	}
	while(t--)
	{
		int n;
	scanf("%d",&n);
	long long sum=s[n]*s[n]-n;
	printf("%lld\n",sum); 
		
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值