codeforces 237c-Primes on Interva

Primes on Interva

lCrawling in process...Crawling failedTime Limit:1000MS    Memory Limit:262144KB     64bit IO Format:%I64d & %I64u

Description

Input

Output

Sample Input

Sample Output

Hint

Description

You've decided to carry out a survey in the theory of prime numbers. Let us remind you that a prime number is a positive integer that has exactly two distinct positive integer divisors.

Consider positive integers a, a + 1, ..., b (a ≤ b). You want to find the minimum integerl (1 ≤ l ≤ b - a + 1) such that for any integerx (a ≤ x ≤ b - l + 1) amongl integers x,x + 1, ..., x + l - 1 there are at least k prime numbers.

Find and print the required minimum l. If no valuel meets the described limitations, print -1.

Input

A single line contains three space-separated integers a, b, k (1 ≤ a, b, k ≤ 106a ≤ b).

Output

In a single line print a single integer — the required minimum l. If there's no solution, print -1.

Sample Input

Input
2 4 2
Output
3
Input
6 13 1
Output
4
Input
1 4 3
Output
-1
 
        
题意:你一个闭区间[a,b],求一个最小的L,使得在区间[a,b-L+1]内任取一个数x,
//可以满足在x,x+1,x+2,……,x+L-2,x+L-1内至少包含k个素数。(1<=a,b,k<=10^6)
#include <stdio.h>
#include <string.h>
int num[1000011], a, b, k;
int s[1000000+11]={1,1};
void su()//筛选素数并计算素数个数 
{
    for(int i = 2; i<1000011; i++){
        num[i] = num[i-1];
        if(s[i])
            continue;
        else num[i]++;//计算素数个数
        for(int j=2*i; j<1000011; j+=i)
            s[j] = 1;
    }
}
int pan(int mid){//二分查找
    for(int i = a; i <= b-mid+1; i++){
        if(num[i+mid-1] - num[i-1] < k)
            return 0;
    }
    return 1;
}
int main(){
    su();
    scanf("%d%d%d", &a, &b, &k);
    if(num[b] - num[a-1] < k){
        printf("-1\n");
        return 0;
    }
    int l = 1, r = b-a+1, t;
    while(r>=l){
        int mid = (l+r)/2;
        if(pan(mid))
            t= mid, r = mid-1;
        else
            l = mid+1;
    }
    printf("%d\n", t);
}
 
        
#include<cstdio>
//#include<algorithm>
//using namespace std;
int a,b,k,num[1000011];
int s[1000000+11]={1,1};
void su()
{
	for(int i=2;i<=1000011;i++)
	{
		num[i]=num[i-1];
		if(s[i]==1)continue;
		else num[i]++;
		for(int j=2*i;j<=1000011;j+=i)
		s[j]=1;
	}
 } 
 int pan(int l)
 {
 	for(int i=a;i<=b-l+1;i++)
 	{
 		if(num[i+l-1]-num[i-1]<k)
 		return 0;
	 }
	 return 1;
 }
 int main()
 {
 	su();
 scanf("%d%d%d",&a,&b,&k);
 if(num[b]-num[a-1]<k)
 printf("-1\n");
 else
 {
 	int l=1,r=b-a+1,t;
 	while(l<=r)
 	{
 		int mid=(l+r)/2;
 		if(pan(mid))
 		t=mid,r=mid-1;
 		else
 		l=mid+1;
	 }
	 printf("%d\n",t);
 }
 return 0;	
 }
 
 
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值