【code forceB】Non-square Equation

Non-square EquationCrawling in process...

Crawling failed Time Limit:1000MS     Memory Limit:262144KB     64bit IO Format:%I64d & %I64u

Description

Input

Output

Sample Input

Sample Output

Hint

Description

Let's consider equation:

x2 + s(xx - n = 0, 

where x, n are positive integers, s(x) is the function, equal to the sum of digits of number x in the decimal number system.

You are given an integer n, find the smallest positive integer root of equation x, or else determine that there are no such roots.

Input

A single line contains integer n (1 ≤ n ≤ 1018) — the equation parameter.

Please, do not use the %lld specifier to read or write 64-bit integers in С++. It is preferred to use cin, cout streams or the %I64d specifier.

Output

Print -1, if the equation doesn't have integer positive roots. Otherwise print such smallest integer x (x > 0), that the equation given in the statement holds.

Sample Input

Input
2
Output
1
Input
110
Output
10
Input
4
Output
-1

Sample Output

Hint

In the first test case x = 1 is the minimum root. As s(1) = 1 and 12 + 1·1 - 2 = 0.

In the second test case x = 10 is the minimum root. As s(10) = 1 + 0 = 1 and 102 + 1·10 - 110 = 0.

In the third test case the equation has no roots.

题解:可看成ax^2+bx+c=0即x^2+bx-n=0;枚举s(x)的值,x^2<10^18 s(x)的范围是0--10*9(90)

           x=(-b+(-)sqrt(b*b-4ac)/2a;

code:

#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
__int64 sum(__int64 m)
{
	__int64 t=0,g;
	__int64 b=m;
	while(b!=0)
	{
		g=b%10;
	    t=t+g;
		b=b/10;	
	}
	return t;
}
int main()
{
	__int64 n,h,x;
	while(~scanf("%I64d",&n))
	{
		int fault=0;
	for(__int64 i=0;i<100;i++)
		{
		 x=-i/2+sqrt(i*i+4*n)/2;
		 if(x*x+sum(x)*x==n)
		 {
		 	fault=1;
		 	h=x;
		 }
		}
		if(fault==1)
		printf("%I64d\n",h);
		else printf("-1\n");
	}
	return 0;
 } 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值