PAT (Basic Level) Practice 1010 一元多项式求导

设计函数求一元多项式的导数。(注:x​n​​(n为整数)的一阶导数为nx​n−1​​。)

输入格式:

以指数递降方式输入多项式非零项系数和指数(绝对值均为不超过 1000 的整数)。数字间以空格分隔。

输出格式:

以与输入相同的格式输出导数多项式非零项的系数和指数。数字间以空格分隔,但结尾不能有多余空格。注意“零多项式”的指数和系数都是 0,但是表示为 0 0

输入样例:

3 4 -5 2 6 1 -2 0

输出样例:

12 3 -10 1 6 0

注意隐含条件

当输入函数零项时:只有0 0

则也要输出:0 0

 

#include <iostream>
#include <vector>
using namespace std;

struct funcTerm {
	int coefficient;
	int exponent;
};


int main() {

	vector<funcTerm> ftList;

	bool isCoefficient = true;
	funcTerm term;
	while ((cin.peek() != EOF) && (cin.peek() != '\n'))
	{
		if (isCoefficient)
		{

			cin >> term.coefficient;
			isCoefficient = false;
		}
		else
		{
			cin >> term.exponent;
			isCoefficient = true;
			ftList.push_back(term);

		}


	}

	for (size_t i = 0; i < ftList.size(); i++)
	{
		if (i ==0&&ftList[i].exponent ==0)
		{
			cout << "0 0";
		}


		if (ftList[i].exponent == 0)
		{
			continue;
		}
		ftList[i].coefficient *= ftList[i].exponent;
		ftList[i].exponent -= 1;

		if (i == 0)
		{
			cout << ftList[i].coefficient << " " << ftList[i].exponent;
		}
		else
		{
			cout << " " << ftList[i].coefficient << " " << ftList[i].exponent;

		}
	}

    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值