PAT (Advanced Level) Practice 1002 A+B for Polynomials

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

 

 

 

题解:

这题有很多坑,改了还几次才过。

注意点:

1.测试案例会有负数项,因此会出现正负项相消的情况

2.注意输出系数时一定一定要用 fixed 不然会出现科学计数法

3.以开始想用 结构体+vector 存储,结果往下写感觉比较麻烦,所以直接用一个hash简单粗暴

 

#include <iostream>
#include <cmath>
#include <iomanip>

using namespace std;


int main()
{

    double hash_poly[1001] = { 0 };
	int n1, n2;
	int count = 0;

	cin >> n1;
	for (int i = 0; i < n1; i++)
	{
		int exp;
		double coef;
		cin >> exp >> coef;

		hash_poly[exp] += coef;

	}

	cin >> n2;
	for (int i = 0; i < n2; i++)
	{
		int exp;
		double coef;
		cin >> exp >> coef;

		hash_poly[exp] += coef;


	}
	for (int i = 0; i < 1001; i++)
	{
		if (hash_poly[i] != 0) count++;
	}

	cout << count;
	for (int i = 1000; i >= 0; i--)
	{
		if (hash_poly[i] == 0)
		{
			continue;
		}
		cout << " " << i << " ";
		cout << fixed << setprecision(1) << hash_poly[i];
	}
	return 0;
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值