PAT 甲级 1060 Are They Equal (25 分)

121 篇文章 0 订阅
115 篇文章 0 订阅

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×10​5​​ with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10​100​​, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]...d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:

3 12300 12358.9

Sample Output 1:

YES 0.123*10^5

Sample Input 2:

3 120 128

Sample Output 2:

NO 0.120*10^3 0.128*10^3

 题解

有点像乙级的那个科学计数法,条件但更复杂些。

小心给出数据的隐含情况 如:000.0000 

                                                 000123456.1234

这类带有无效0的输入

大概思路:将输入数字分成大于1的数   如123456.454

与小于1的数  如 0.000001456

对数字进行处理(删除前导0,小数点,小数点后与无效的0)只保留有效数字并返回

#include <iostream>
#include <string>

using namespace std;


string deal(string s, int &e, int n) {

	int k = 0;
	while (s.length() > 0 && s[0] == '0') s.erase(s.begin()); //删掉前面所有无效的0

	if (s[0] == '.') //当前数为小于一的数
	{
		s.erase(s.begin());//删掉小数点
		while (s.length() > 0 && s[0] == '0')
		{
			s.erase(s.begin());
			e--;
		}
	}
	else
	{
		while (k < s.length() && s[k] != '.')//寻找小数点,修改指数e
		{
			k++;
			e++;
		}

		if (k < s.length()) s.erase(s.begin() + k);//找到了小数点并删除
	}

	if (s.length() == 0) e = 0;//当去掉所有不需要的0后字符串长度为0 说明该数即为0 重置指数

	int num = 0;
	k = 0;

	string res = "";
	while (num < n)
	{
		if (k < s.length()) res += s[k++];
		else res += '0';
		num++;
	}
	return res;
}


int main() {

	int n, e1 = 0, e2 = 0;
	string a, b;
	cin >> n >> a >> b;

	string s1, s2;

	s1 = deal(a, e1, n);
	s2 = deal(b, e2, n);

	if (s1 == s2 && e1 == e2) cout << "YES 0." << s1 << "*10^" << e1 << '\n';
	else cout << "NO 0." << s1 << "*10^" << e1 << " 0." << s2 << "*10^" << e2 << '\n';
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值