1060 Are They Equal (25 分)

1060 Are They Equal (25 分)

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×10^​5​ with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10
​100
​​, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]…d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.
Note: Simple chopping is assumed without rounding.

Sample Input 1:

3 12300 12358.9

Sample Output 1:

YES 0.123*10^5

Sample Input 2:

3 120 128

Sample Output 2:

NO 0.120*10^ 3 0.128 * 10^3

Note

  1. 题意: 保留n位小数,看两数是否相等
  2. 思路: substring法,
  3. 错误点: 没有考率到
    • 0.002小数点后有无效位的这种情况
    • 0.001小数的也给直接切掉了

Code

#include<iostream>
#include<string>
#include<fstream>
using namespace std;
int main(){
    int pos;
    string a, b;
    //ifstream cin("data.txt");
    cin >> pos >> a >> b;
    string sub_a = a.substr(0, pos  );
    string sub_b = b.substr(0, pos  );
    if(sub_a == sub_b){
        cout << "YES ";
        int temp = 0;
        while(a[temp] != '.' && temp < a.length()){
            temp++;
        }
        cout << "0." << sub_a << "*10^" << temp;
    }
    else {
        cout << "NO ";
        int temp = 0;
        while(a[temp] != '.' && temp < a.length()){
            temp++;
        }
        cout << "0." << sub_a << "*10^" << temp << " ";
        temp = 0;
        while(b[temp] != '.' && temp < b.length()){
            temp++;
        }
        cout << "0." << sub_b << "*10^" << temp;
    }

}

(17)

Note2

  1. 数据分类
    在这里插入图片描述
  2. 处理注意:可能存在有效位不够的情况, 后面要补零
#include<iostream>
#include<string>
using namespace std;
int n;
string deal(string s, int &e){
    int k = 0;
    while(s.length() >  0 && s[0] == '0'){
        s.erase(s.begin());
    }// delete 前导零
    if(s[0] == '.'){
        s.erase(s.begin());
        while(s.length() > 0 && s[0] == '0'){
            s.erase(s.begin());
            e--;
        }//0.002
    }
    else{
        while(k < s.length() && s[k] != '.'){
            k++;
            e++;
        }
        if(k < s.length()){
            s.erase(s.begin() + k);
        }
    }
    if(s.length() == 0){
        e = 0;//0.00
    }
    int num = 0;
    k = 0;
    string res;
    while(num < n){
        if(k < s.length()) res += s[k++];
        else res +=  '0';
        num++;
    }//0.1 取三位 0.100
    return res;
}
int main(){
    string s1, s2, s3, s4;
    cin >> n >> s1 >> s2;
    int e1 = 0, e2 = 0;
    s3 = deal(s1, e1);
    s4 = deal(s2, e2);
    if(s3 == s4 && e1 == e2){
        cout << "YES 0."<< s3 <<"*10^" << e1 << endl;
    }
    else{
        cout << "NO 0." << s3 << "*10^" << e1 << " 0." << s4 << "*10^" << e2 << endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值